cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie
Newbie
386 Views
Registered: ‎09-20-2019

Problem with xilinx-u250-xdma-201820

Hi all,

I have had a problem running Image_classification_tensorflow on Alveo u250.

When I use xilinx-u250-201830 from the OS side all the xbutil validate and query runs successfully but when I run image_classification_tensorflow I get Runtime Error: could not init FPGA: xclbin.

I followed this link:

https://forums.xilinx.com/t5/Xilinx-ML-Suite/RuntimeError-Could-not-init-FPGA-upon-runing-image/td-p/1016294

mentioning that the "overlaybins provided by xilinx ml-suite supports only 2018.2 xrt and xdma environment". I followed this link:

https://www.xilinx.com/products/acceleration-solutions/xilinx-machine-learning-suite.html#gettingStartedU250

and installed xilinx-u250-xdma-201820. When I tried to flash the card, it says the DSA version is not applicable and the xbutil validate and query returns the following:

xbutil validate
INFO: Found 1 cards
ERROR: Failed to open device: 0000:03:00.0
ERROR: Can't open card[0]

ERROR: Some cards failed to validate.

xbutil query
Failed to open device: 0000:03:00.0
INFO: Found total 1 card(s), 0 are usable
ERROR: Card [0] is not ready
 
 
Any help would be sincerely appreciated
0 Kudos
2 Replies
Highlighted
Contributor
Contributor
311 Views
Registered: ‎11-08-2018

Re: Problem with xilinx-u250-xdma-201820

Hi @sshams2

Can you give you os details?

 

Regards,

V Durga

0 Kudos
Highlighted
Newbie
Newbie
289 Views
Registered: ‎09-20-2019

Re: Problem with xilinx-u250-xdma-201820

Hi,

Thanks for your response.

Here is the os information

lsb_release -a
LSB Version: :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID: CentOS
Description: CentOS Linux release 7.5.1804 (Core)
Release: 7.5.1804
Codename: Core

0 Kudos