UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor cheesybread
Visitor
108 Views
Registered: ‎05-29-2019

AXI-DMA S2MM problem - DMA receives data stream but doesn't send to processor

Hi experts,

I'm using the Pynq Z-1 board.

I have a DMA set up to receive a stream of data from the XADC and send the data to ps7_0 via a smart connect, however this process isn't working. I checked the signals and made sure that the DMA was receiving the data properly. 

M_AXI_S2MM_wvalid never is high despite receiving data. I checked all the write address signals and they work properly. Does anyone have thoughts as to why the DMA won't be sending data to the AXI SmartConnect?

Let me know if you need me to provide more information.

0 Kudos
1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
67 Views
Registered: ‎10-12-2018

Re: AXI-DMA S2MM problem - DMA receives data stream but doesn't send to processor

Hi @cheesybread ,

In S2MM transfer, the AXI DMA moves transfers from the streaming side to the memory mapped side until TLAST is asserted. what is the value of S2MM_LENGTH ? 

Can you please provide the screen shot of your waveforms and AXI DMA configuration?

Thanks & Regards
Anil B
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos