UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer hulkakos
Observer
8,563 Views
Registered: ‎12-12-2007

PAR problem

Jump to solution

During the place and route of a project  it shows the following error: .
ERROR:Place:592 - A clock IOB / BUFGCTRL clock component pair have been found that are not placed at an optimal clock
   IOB / BUFGCTRL site pair. The clock IOB component <clk> is placed at site <AE14>. And the corresponding BUFG
   component <bufgp_0/BUFG> is placed at site <BUFGCTRL_X0Y30> The clock IO site can use the fast path between the IO
   and the Clock buffer if the IOB & BUFGCTRL are both placed in the same half of the device (TOP or BOTTOM). You may
   want to analyze why this problem exists and correct it. If this sub optimal condition is acceptable for this design,
   you may set the environment variable XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING to demote this message to a WARNING and allow
   your design to continue.

 

can anyone tell me from where can i set the environment variable XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING in order to continue the implementation of the project?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
9,266 Views
Registered: ‎03-18-2008

Re: PAR problem

Jump to solution

There are two ways to do this.

 

1) Click on the tcl tab at the bottom of the gui.  Type

set XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING=1

 

Setting this variable from the tcl window will allow this setting for the current session only.  If you close and reopen ISE, you will need to type this back in to enable the setting for each new session

 

2)(WINDOWS OS) Right click on my computer and go to properties.   Click on the advanced tab and click on the environment variables button.  Under the user variable section,click on the new button and add XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING as the variable name and enter 1 as the value.

 

(LINUX OS) in a console window, type setenv XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING=1

 

Make sure that you restart the ISE tools after you add the environment variable.  You don't need to restart your computer.

2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
9,267 Views
Registered: ‎03-18-2008

Re: PAR problem

Jump to solution

There are two ways to do this.

 

1) Click on the tcl tab at the bottom of the gui.  Type

set XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING=1

 

Setting this variable from the tcl window will allow this setting for the current session only.  If you close and reopen ISE, you will need to type this back in to enable the setting for each new session

 

2)(WINDOWS OS) Right click on my computer and go to properties.   Click on the advanced tab and click on the environment variables button.  Under the user variable section,click on the new button and add XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING as the variable name and enter 1 as the value.

 

(LINUX OS) in a console window, type setenv XIL_PLACE_ALLOW_LOCAL_BUFG_ROUTING=1

 

Make sure that you restart the ISE tools after you add the environment variable.  You don't need to restart your computer.

Observer hulkakos
Observer
8,530 Views
Registered: ‎12-12-2007

Re: PAR problem

Jump to solution
Thank you very much. I'ts working!
0 Kudos