UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
11,299 Views
Registered: ‎02-04-2016

Disable bit and byte swap using write_cfgmem ?

Jump to solution

How to disable the bit and byte swap when I use write_cfgmem command?  I belive -disablebitswap option is no longer supported. what is the exact syntax i have to use. Should i change the interface to SelectMap or Serial1x or something? Please help. As of now I use the one below. and it says -disablebitswap is no longer supported. Please help.

write_cfgmem -format BIN -interface SMAPx32 -disablebitswap -loadbit "up 0 Bitstreams/Config_add_pblock_rp_instance_partial.bit" Bitstreams/add.bin
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
21,345 Views
Registered: ‎02-04-2016

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

@pratham

Hey,

I am mentioning about the tutorial in the link http://www.xilinx.com/support/university/vivado/vivado-workshops/Vivado-partial-reconfiguration-flow-zynq.html  . You can see towards the right of this page ,2015x workshop material. I specifically had issue with the lab-3. But I must tell you that problem is solved now when I used  write_cfgmem command in 2015.4 lab edition which do not need license after doing  partial reconfiguration part in 2014.2( which i had license for) . Lab-3 works now with no issues . Thanks for the help.

 

But,

 

You can notice in lab that its all done in standalone mode. Can I do the same in Linux Application mode too? Basically they had linked the standalone user application "TestApp" with Standalone BSP . But Can I create the same TestApp as a linux user application? I tried creating TestApp as Linux Application , but unfortunately it gives error "xparameters.h" not found, even though I had included them. I doubt if I should use a diferent bsp for linux application? Do you have any suggestions?  Also , I can post it as a new thread if required. 

 

0 Kudos
10 Replies
Xilinx Employee
Xilinx Employee
11,284 Views
Registered: ‎10-24-2013

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

Hi @gouthamp

 

I think you are using older versions of Vivado (probably 2014.3 or older).

Please use 2014.4 or later where disablebitswap is supported.

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
Adventurer
Adventurer
11,265 Views
Registered: ‎02-04-2016

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

Hi @vijayak,

 

Thanks for the response. Yes you are right. I am using 2014.2. For the time being, I used "serialx1" as inteface option in write_cfgmem to avoid bit reversal. I beleive it is right. Isnt? I could not verify yet.

Also, I will upgrade to 2014.4+ soon!  :)

0 Kudos
Xilinx Employee
Xilinx Employee
11,249 Views
Registered: ‎10-24-2013

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

Hi @gouthamp

 

Iam not sure if that works. Quick thing would be to migrate to the latest version of Vivado 2015.4

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
Scholar pratham
Scholar
11,240 Views
Registered: ‎06-05-2013

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

@gouthamp .MCS file created for spi x1,2,4 are not bit swapped in any of the vivado version. You dont have to use -disablebitswap for spi mode.  You can use the existing vivado version as well :)

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Adventurer
Adventurer
11,213 Views
Registered: ‎02-04-2016

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

Thanks. I am creating .bin format though, not .MCS .  Is the case same?

0 Kudos
Scholar pratham
Scholar
11,194 Views
Registered: ‎06-05-2013

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

@gouthamp Yes same for .bin file as well.

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
11,161 Views
Registered: ‎02-04-2016

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

@vijayak and @pratham I tried upgrading to 2015.2 , but unfortunately license for 2015.2 does not have partial reconfiguration license included in it. University  hav requested again to the University Relations Manager I believe. 

 

Meanwhile I am trying for a workaround with 2014.2 . I am basically trying to replicate the partial recongiration tutorial provided by Xilinx . 

write_bitstream -file Bitstreams/blanking.bit 
write_cfgmem -format BIN -interface SMAPx32 -disablebitswap -loadbit "up 0 Bitstreams/blanking_pblock_rp_instance_partial.bit" Bitstreams/blank.bin

What is the exact 2014.2 version for write_cfgmem without -disablebitswap . This is what I have done .

write_bitstream -file Bitstreams/blanking.bit 
write_cfgmem -format BIN -interface SERIALX1 -loadbit "up 0 Bitstreams/blanking_pblock_rp_instance_partial.bit" Bitstreams/blank.bin

Everything goes well , binary is being created  , but partial bit streams loading to fpga does not make any impact. The Done LED on board is always ON because it has the static configuration on it. Does it gets off and on to prove that partial bit streams are loaded? However, I am not getting the expected output of the partial bitstreams.(basically a multiplication and addition as two bit streams, whatever operand I give , it returns 0 ,which must  the output after blanking the PR part or may be the only with static  part.

Baic question is  " Is my version of write_cfgmem  similar to the one in the tutorial ,which produces binary bit file in the format that Xdevcfg driver can read?  If not, what is the substitute to do similar in 2014.2. 

0 Kudos
Scholar pratham
Scholar
11,132 Views
Registered: ‎06-05-2013

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

@gouthamp Can you let us know what tutorial are you referring? 

 

Are you using .bin generated with 2015.2 and programming it using 2014.2?

Did 2014.2 .bin file also not working?

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Adventurer
Adventurer
21,346 Views
Registered: ‎02-04-2016

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

@pratham

Hey,

I am mentioning about the tutorial in the link http://www.xilinx.com/support/university/vivado/vivado-workshops/Vivado-partial-reconfiguration-flow-zynq.html  . You can see towards the right of this page ,2015x workshop material. I specifically had issue with the lab-3. But I must tell you that problem is solved now when I used  write_cfgmem command in 2015.4 lab edition which do not need license after doing  partial reconfiguration part in 2014.2( which i had license for) . Lab-3 works now with no issues . Thanks for the help.

 

But,

 

You can notice in lab that its all done in standalone mode. Can I do the same in Linux Application mode too? Basically they had linked the standalone user application "TestApp" with Standalone BSP . But Can I create the same TestApp as a linux user application? I tried creating TestApp as Linux Application , but unfortunately it gives error "xparameters.h" not found, even though I had included them. I doubt if I should use a diferent bsp for linux application? Do you have any suggestions?  Also , I can post it as a new thread if required. 

 

0 Kudos
Scholar pratham
Scholar
9,533 Views
Registered: ‎06-05-2013

Re: Disable bit and byte swap using write_cfgmem ?

Jump to solution

@gouthamp Glad to know. Please feel free to start a new thread under embedded board and close this one.

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos