cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
nebenni
Observer
Observer
1,312 Views
Registered: ‎05-08-2018

Bug: Vivado 2017.4 crashing on rightclick in console/log

Jump to solution

When i open Vivado, but not a project, a right click in the console opens the context-menu, as expected.

 

After opening a project (i tried a few different ones), right clicking in "Log" or "Tcl Console" immediately crashes vivado.

The tabs "Messages", "Reports" and "Design Runs" are not affected by this.

 

In the hs_err_pidXXXX.log files i always get something similar to this:

#
# An unexpected error has occurred (11)
#
Stack:
/opt/Xilinx/Vivado/2017.4/tps/lnx64/jre/lib/amd64/server/libjvm.so(+0x923da9) [0x7f666cf5eda9]
/opt/Xilinx/Vivado/2017.4/tps/lnx64/jre/lib/amd64/server/libjvm.so(JVM_handle_linux_signal+0xb6) [0x7f666cf653f6]
/opt/Xilinx/Vivado/2017.4/tps/lnx64/jre/lib/amd64/server/libjvm.so(+0x9209d3) [0x7f666cf5b9d3]
/lib/x86_64-linux-gnu/libc.so.6(+0x35fc0) [0x7f66a993efc0]
/opt/Xilinx/Vivado/2017.4/tps/lnx64/jre/lib/amd64/libawt_xawt.so(+0x42028) [0x7f664e24d028]
/opt/Xilinx/Vivado/2017.4/tps/lnx64/jre/lib/amd64/libawt_xawt.so(+0x42288) [0x7f664e24d288]
/opt/Xilinx/Vivado/2017.4/tps/lnx64/jre/lib/amd64/libawt_xawt.so(Java_sun_awt_X11_XRobotPeer_getRGBPixelsImpl+0x17c) [0x7f664e24567c]
[0x7f665cffe4cf]

Operating System is Linux (Debian 64 Bit).

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
nebenni
Observer
Observer
1,325 Views
Registered: ‎05-08-2018
Thanks for the answer. I'm using Debian, which is the base of Ubuntu (which is supported). I searched a bit more on the web and found this: https://wiki.archlinux.org/index.php/Xilinx_Vivado It seems the problem i have is based on Vivado expecting X11, but me having Wayland enabled. Disabling Wayland worked for me...

View solution in original post

2 Replies
prathikm
Moderator
Moderator
1,287 Views
Registered: ‎09-15-2016

Hi @nebenni,

 

Can you please confirm you are using supported OS platform for Vivado 2017.4?

Check page.9 of Xilinx User Guide UG973 (link).

 

Prathik

-----------------------------------------------------------------------------------

Don't forget to reply, kudo, and mark the appropriate post as 'accept as solution'.

-----------------------------------------------------------------------------------

0 Kudos
nebenni
Observer
Observer
1,326 Views
Registered: ‎05-08-2018
Thanks for the answer. I'm using Debian, which is the base of Ubuntu (which is supported). I searched a bit more on the web and found this: https://wiki.archlinux.org/index.php/Xilinx_Vivado It seems the problem i have is based on Vivado expecting X11, but me having Wayland enabled. Disabling Wayland worked for me...

View solution in original post