UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor rajesh_s
Visitor
1,378 Views
Registered: ‎11-01-2019

GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

Hi,

I've just made a fresh install of 2019.2 on Ubuntu 18.04. 

I've also sourced Vivado/2019.2/settings64.sh

However, when I try invoking the GUI, I get this error

rajesh@mypc:~$ vivado

****** Vivado v2019.2 (64-bit)
  **** SW Build 2700185 on Thu Oct 24 18:45:48 MDT 2019
  **** IP Build 2699827 on Thu Oct 24 21:16:38 MDT 2019
    ** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

start_gui
ERROR: [Common 17-267] Couldn't open 'libjvm.so': 'libjvm.so: cannot open shared object file: No such file or directory'
Make sure you are using a supported OS of RHEL5.x or greater.

ERROR: [Common 17-211] Error loading jvm.
Vivado% 
Vivado% 

What could I be missing here?

Thank you for your time.
Rajesh

 

0 Kudos
1 Solution

Accepted Solutions
Observer tobeychris
Observer
708 Views
Registered: ‎09-16-2013

Xilinx Official Answer Record

Jump to solution

Official Xilinx AR73047 

Solution

During the install there are files that do not have the appropriate user permissions for other users to launch the tools. 

To correct this, use the following commands on the install directory to copy the group permissions to the user permissions.

Note: if the install was done with sudo, these commands should be run with sudo.

Vivado Install:

chmod -R o=g <install_dir>/Vivado/2019.2/tps/lnx64/jre9.0.4
chmod -R o=g <install_dir>/.xinstall/Vivado_2019.2/tps/lnx64/jre9.0.4

Vitis Install:

chmod -R o=g <install_dir>/Vitis/2019.2/tps/lnx64/jre9.0.4
chmod -R o=g <install_dir>/Vivado/2019.2/tps/lnx64/jre9.0.4
chmod -R o=g <install_dir>/.xinstall/Vitis_2019.2/tps/lnx64/jre9.0.4

 

View solution in original post

12 Replies
Visitor rajesh_s
Visitor
1,374 Views
Registered: ‎11-01-2019

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

Okay the issue is not with dependencies. Looks like it's to do with ownership of files.
 
I went to "cd /opt/Xilinx/Vivado/2019.2/bin" and then tried to invoke vivado using "sudo ./vivado" and it works as expected. The GUI opens without any issues.

I had used the following to avoid having to use sudo everytime I need to use Vivado

sudo chown -hR $USER:$USER $HOME/.Xilinx/

 Is sudo always needed? What's the recommended way to go about this?

Thanks,
Rajesh

Highlighted
Observer wgabor
Observer
1,222 Views
Registered: ‎01-22-2019

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

My fixes:

sudo chmod 755 -R /opt/Xilinx/Vitis/2019.2

sudo chmod 755 -R/opt/Xilinx/Vivado/2019.2

Observer wgabor
Observer
1,188 Views
Registered: ‎01-22-2019

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

Note, this is an _ugly_ _hack_, hopefully won't break anything.

0 Kudos
Moderator
Moderator
1,171 Views
Registered: ‎06-14-2010

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

Hello @rajesh_s,

Indeed, this behaviour is due to the read write and execute permissions currently set on /opt/ folder.

The default installation path on Linux is /opt/Xilinx, and for most users root privileges is required to write to /opt.

To work around this issue users can either do the following (this is prior the Vivado/Vitis installation):

sudo mkdir /opt/Xilinx

sudo chmod 777 /opt/Xilinx 

Now you have read, write and execute permissions to install as any user and any user can then run the installer as themselves (without sudo).

Or, if the tools are already installed, then, as correctly suggested by @wgabor , you can set the correct read, write and execute permissions (sudo chmod 777) or just read and execute permissions (sudo chmod 755) in this case, and you can overcome this issue then.

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer wgabor
Observer
1,169 Views
Registered: ‎01-22-2019

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

Note:

NEVER do chmod 777 on any files, if possible.

You don't want to give write permission for EVERY user on your system for a given file. Shall I mention the security issues of this?

755 is more than enough in this case.

0 Kudos
1,157 Views
Registered: ‎12-27-2016

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

I think your solution will only work for the user who did the installation not the others, which is major issue.

Moreover, I don't think that chmod 755 (or even worse: 777) is a solution because it adds execution permission to all the files in the install directory. It is nearly as dirty as running Vivado/Vitis with sudo.

0 Kudos
Observer wgabor
Observer
1,151 Views
Registered: ‎01-22-2019

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

As I said in https://forums.xilinx.com/t5/Design-Entry/GUI-fails-to-open-after-installing-2019-2-on-Ubuntu-18-04-3-LTS/m-p/1039252/highlight/true#M22381: dirty hack.

You can try to find every .so file (I tried that too), but it was still not enough, so I came up with this quick workaround. Clearly Xilinx should fix it... (seems they have some serious testing issues considering this bug and https://forums.xilinx.com/t5/Design-Entry/Vivado-2019-1-java-error-on-start-gui-with-multiple-monitors/td-p/983998 ...

Note: this problem did not arise on my home PC with Arch Linux.

0 Kudos
Voyager
Voyager
1,071 Views
Registered: ‎01-28-2008

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

The Vivado 2019.2 installation copies files into /tools/Xilinx by default, with permissions 750, meaning full read/write/exec permissions for the installing user (normally root), read/exec permissions for the group, and none for all others. This is different from previous installations, where 755 was the norm for all files in the install, and means that if root did the installation, all users could read and execute the installed files.

So there's a few things to try to fix in this installation.

a) Before the install, set the installation directory permissions to a permissible user-group-others setting. For example, user 'admin', group 'users' such that all users in the system belonging to 'users' group can access Vivado.

b) After the installation is done, change the group permissions to a common group, such as 'users'. A simple command would suffice:

sudo chgrp -hR users /opt/Xilinx/

c) Change all files in installation that don't have read permissions for 'others', to have 'others' read/exec permissions. For example:

find /opt/Xilinx/ -type f ! -perm -o+r -print -exec chmod o+rx '{}' \;

Any of these options should work around the issue. I believe Xilinx should fix these permissions to be the same as previous installs.

Thanks,

-Pat

 

 

https://tuxengineering.com
Contributor
Contributor
1,051 Views
Registered: ‎07-01-2008

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

Thanks @patocarr 

Option C in your post with the modified command to only modify files under /opt/Xilinx/Vivado/2019.2 solved the problem for me.

find /opt/Xilinx/Vivado/2019.2 -type f ! -perm -o+r -print -exec chmod o+rx '{}' \;

 

Shant

0 Kudos
Observer tobeychris
Observer
934 Views
Registered: ‎09-16-2013

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

This only needs to be applied to the files under:

/opt/xilinx/Vivado/2019.2/tps/lnx64/jre9.0.4

Fixing the permissions on that folder (or copying that folder from 2019.1) was all that was required to fix the install for us.

Observer tobeychris
Observer
709 Views
Registered: ‎09-16-2013

Xilinx Official Answer Record

Jump to solution

Official Xilinx AR73047 

Solution

During the install there are files that do not have the appropriate user permissions for other users to launch the tools. 

To correct this, use the following commands on the install directory to copy the group permissions to the user permissions.

Note: if the install was done with sudo, these commands should be run with sudo.

Vivado Install:

chmod -R o=g <install_dir>/Vivado/2019.2/tps/lnx64/jre9.0.4
chmod -R o=g <install_dir>/.xinstall/Vivado_2019.2/tps/lnx64/jre9.0.4

Vitis Install:

chmod -R o=g <install_dir>/Vitis/2019.2/tps/lnx64/jre9.0.4
chmod -R o=g <install_dir>/Vivado/2019.2/tps/lnx64/jre9.0.4
chmod -R o=g <install_dir>/.xinstall/Vitis_2019.2/tps/lnx64/jre9.0.4

 

View solution in original post

Xilinx Employee
Xilinx Employee
705 Views
Registered: ‎01-11-2011

Re: GUI fails to open after installing 2019.2 on Ubuntu 18.04.3 LTS

Jump to solution

We now have an Answer Record on this issue with the necessary chmod commands to allow the tools to launch:

https://www.xilinx.com/support/answers/73047.html

-------------------------------------------------------------------------
Please don’t forget to reply, kudo, and accept as solution!
-------------------------------------------------------------------------