UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor dtodorovtu
Visitor
52 Views
Registered: ‎12-05-2018

Vivado cannot detect modules in HDL files [filemgtmt 20-2001]

Hello,

recently I switched over from Vivado 2016.3 to 2018.1.

When re-opening an already existing project I get prompted to 'convert' it to the new vivado version, so I agree. However, all the HDL files are then not recognized and are kept under "Non-module" files category. Furthermore, I cannot select a top-level module for neither design, nor simulation. In the message lane I get these:

 

2018-12-06 08_58_15-Clipboard.png

 

 

I also tried staring a project from scratch and adding-in HDL files manually, unfortunately outcome was the same.

Searching through this forum, it seems there are many instances of this problem across users with vivado versions newer than 2016.4, but now clear solution is stated, only some hints that have arbitrary effects.

Has anybody got a confirmed solution (except for reverting back to 2016.3/4 versions) to this issue? I have tried mostly everything menitoned in the threads - rebooting, deleting AppData files, changing to 2018.2 (prblem persists), re-installing VC++ libs, copying files to /src/sources_1/ directories, but nothing really helped so far. FYI, I'm running Win7 x64 Ultimate SP1.

Thanks,

Dimitar

2018-12-06 08_58_15-Clipboard.png
0 Kudos