UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant bmarsolais
Participant
6,127 Views
Registered: ‎01-16-2012

Vivado won't open IP product guides

I am running Vivado 16.2 under Ubuntu 14.04.  When I right click on an IP block in a block diagram and select IP Documentation > "View Product Guide" or "View Product Webpage" or "View Answer Records", nothing happens.  However I can always view the change log.  I have tried this on several different blocks an always get the same result.  I can run a design all the way through Program and Debug.  Why is this happening?

Thanks, Bob
9 Replies
Xilinx Employee
Xilinx Employee
6,097 Views
Registered: ‎08-01-2008

Re: Vivado won't open IP product guides

1. check the release note if you installed supported version of tools
2. Check your license and environment variable
3. Re run the installation and make sure you have installed the documentation

http://www.xilinx.com/support/answers/50463.html

5. you can search document online on xilinx web

http://www.xilinx.com/products/design-tools/vivado.html
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Xilinx Employee
Xilinx Employee
6,093 Views
Registered: ‎07-31-2012

Re: Vivado won't open IP product guides

Do you have docnav installed? This link opens in DocNav rather than a web browser.

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.
0 Kudos
Participant bmarsolais
Participant
6,056 Views
Registered: ‎01-16-2012

Re: Vivado won't open IP product guides

When checking to make sure all conditions you specified were met, I found the following message in the terminal window when I tried to run DocNav.  (I do not have the Xilinx program group installed but that is a problem for another time when I have the time.)

 

ERROR: Socket server not listening. QLocalServer::listen: Address in use
 
Restart of the local socket server was successful.
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
/opt/Xilinx/Vivado/2016.2/ids_lite/ISE/lib/lin64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/firefox/libxul.so)
Couldn't load XPCOM.

 

This message appears every time I try to use DocNav.  I did a search in the Ubuntu Software Center for GLIBXX_3.4.15 and could not find anything.  Any ideas?  Xilinx used to have a list of dependencies that had to be installed.  The list was in the installatio manual, but it is no longer there.

 

Thanks, Bob
0 Kudos
Participant bmarsolais
Participant
5,850 Views
Registered: ‎01-16-2012

Re: Vivado won't open IP product guides

Yes, DocNav is installed but also will not run.  Please see my last post and see if it gives you any ideas.

 

Thanks, Bob

 

Thanks, Bob
0 Kudos
Observer caryan
Observer
5,796 Views
Registered: ‎04-17-2014

Re: Vivado won't open IP product guides

Xilinx ships a `libstdc++` and when you source the `settings64.sh` script it puts the Xilinx shipped libraries at the front of the `LD_LIBRARY_PATH`. The `libstdc++` shipped for ISE is quite old and your system Firefox is expecting a newer version.

 

 

strings /opt/Xilinx/Vivado/2016.1/ids_lite/ISE/lib/lin64/libstdc++.so | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_FORCE_NEW

c.f.

strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBCXX_3.4.21
GLIBCXX_DEBUG_MESSAGE_LENGTH

Since your system already has a newer `libstdc++` on the path which should be backwards compatible you could try renaming the Xilinx shipped one

 

mv /opt/Xilinx/Vivado/2016.1/lib/lnx64.o/libstdc++.so.6 /opt/Xilinx/Vivado/2016.1/lib/lnx64.o/libstdc++.annoying

 

 

 

0 Kudos
Highlighted
Participant bmarsolais
Participant
5,782 Views
Registered: ‎01-16-2012

Re: Vivado won't open IP product guides

@caryan  Thanks for the reply.  I tried what you suggested and it did not fix the problem.  After doing what you suggested, I then ran sudo apt-get -update and "sudo apt-get - dist-upgrade", reopened Vivado, and tried to open an IP product guide by right-clicking on an IP block within a block diagram.  The new message is:

 

QLocalSocket::connectToServer: Connection refused

 

Any ideas?

 

Thanks, Bob
0 Kudos
Participant bmarsolais
Participant
5,777 Views
Registered: ‎01-16-2012

Re: Vivado won't open IP product guides

@caryan  I should add I got the same error message after making the changes you suggested and before I ran sudo apt-get dist-upgrade.  Your changes resulted in the new error message.  My upgrade didn't change anything.

Thanks, Bob
0 Kudos
Participant bmarsolais
Participant
5,770 Views
Registered: ‎01-16-2012

Re: Vivado won't open IP product guides

Latest update:  I have declared Firefox, Chromium, and the Debian "sensible" browser, the Ubuntu 14.04 default browser, as the default browsers and tried to open an IP product guide from within Vivado.  All three fail giving messages like "browser failed to open" or the like.  All three of those browsers open correctly and can browse various web pages when directly called with no problem.  Could perhaps this be a Xilinx bug?

Thanks, Bob
0 Kudos
Observer caryan
Observer
5,760 Views
Registered: ‎04-17-2014

Re: Vivado won't open IP product guides

@bmarsolais are you still getting the GLIBCXX even after renaming the files?  I get the socket error every second time I try and open a product guide but if I just try again it works and my console looks something like:

 

cryan@cryan-Precision-5510 ~/Programming/Repos/APS3-KCU105 $ vivado

****** Vivado v2016.1 (64-bit)
  **** SW Build 1538259 on Fri Apr  8 15:45:23 MDT 2016
  **** IP Build 1537824 on Fri Apr  8 04:28:57 MDT 2016
    ** Copyright 1986-2016 Xilinx, Inc. All Rights Reserved.

Sourcing tcl script '/home/cryan/.Xilinx/Vivado/init.tcl'
start_gui
Gtk-Message: Failed to load module "atk-bridge"

(docnav:6539): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
Created new window in existing browser session.
Gtk-Message: Failed to load module "atk-bridge"

(docnav:6800): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
QLocalSocket::connectToServer: Connection refused
Gtk-Message: Failed to load module "atk-bridge"
0 Kudos