UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer wscomm
Observer
157 Views
Registered: ‎07-30-2015

SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. System works fine. Tried moving the new memory to older ZCU102-Z1 Ver 1.0 and running build. Halts in FSBL. Using Vivado 17.4 hardware chain and using 17.3 SDK.

0 Kudos
1 Solution

Accepted Solutions
Observer wscomm
Observer
32 Views
Registered: ‎07-30-2015

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Well we seemed to resolve the issue ... we had to set the configuration to DDR-2400P. Again this is 17.4 ... bottom line trc, tcas and tras had to be tweaked.

 

Thanks again for all the help.

 

 

image.pngCurrent working solution

7 Replies
Xilinx Employee
Xilinx Employee
120 Views
Registered: ‎10-12-2018

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Hi @wscomm ,

Would it be possible to provide more details on halts in FSBL?

Please check this AR, if you haven't referred already. Hope it helps you.

https://www.xilinx.com/support/answers/71961.html

 

Thanks & Regards

Anil B

0 Kudos
Observer wscomm
Observer
97 Views
Registered: ‎07-30-2015

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Enable debug messages from the FSBL and found that the config_done could not be confirmed halting processing. We tried confirming config_done success and was able to reach the uboot ATF which failed. This modified build was not able to run on the 1.1 hardware. 

My best guess is that the PMU firmware is not playing correctly with the FSBL and UBOOT functionality. 

Is there anyway to update the PMU firmware on the 1.0 hardware?

Idea appreciated,

Thanks

 

 

Xilinx Zynq MP First Stage Boot Loader
Release 2017.3 May 13 2019 - 13:21:07
Reset Mode : System Reset
Platform: Silicon (4.0), Cluster ID 0x80000000
Running on A53-0 (64-bit) Processor, Device Name: XCZU9EG
Board Configuration successful
Processor Initialization Done
================= In Stage 2 ============
SD1 with level shifter Boot Mode
Programming 156.25 MHZ Clock for 10G MAC
Hello IIC SI5338 and SI570 Clock Test.

inside SI570 clock programming
IIC Switch Config Read Value 0x8
clock programming success
Programming 156.25 MHZ Clock for 10G MAC success
SD: rc= 0
File name is BOOT.BIN
Multiboot Reg : 0x0
Image Header Table Offset 0x8C0
*****Image Header Table Details********
Boot Gen Ver: 0x1020000
No of Partitions: 0x5
Partition Header Address: 0x440
Partition Present Device: 0x0
Initialization Success
======= In Stage 3, Partition No:1 =======
UnEncrypted data Length: 0x1800
Data word offset: 0x1800
Total Data word length: 0x1800
Destination Load Address: 0xFFFEA000
Execution Address: 0xFFFEA000
Data word offset: 0xF5B0
Partition Attributes: 0x117
Partition 1 Load Success
======= In Stage 3, Partition No:2 =======
UnEncrypted data Length: 0x8
Data word offset: 0x8
Total Data word length: 0x8
Destination Load Address: 0xFFFF0000
Execution Address: 0x0
Data word offset: 0x10DB0
Partition Attributes: 0x117
Partition 2 Load Success
======= In Stage 3, Partition No:3 =======
UnEncrypted data Length: 0x2D662
Data word offset: 0x2D662
Total Data word length: 0x2D662
Destination Load Address: 0x8000000
Execution Address: 0x8000000
Data word offset: 0x10DC0
Partition Attributes: 0x114
Partition 3 Load Success
======= In Stage 3, Partition No:4 =======
UnEncrypted data Length: 0x65216F
Data word offset: 0x65216F
Total Data word length: 0x65216F
Destination Load Address: 0xFFFFFFFF
Execution Address: 0x0
Data word offset: 0x3E430
Partition Attributes: 0x26
Destination Device is PL, changing LoadAddress
Non authenticated Bitstream download to start now

????????????????????????????????????????????????????????
Missing for this stage:
????????????????????????????????????????????????????????
DMA transfer done
PL Configuration done successfully
Partition 4 Load Success
All Partitions Loaded

================= In Stage 4 ============
PM Init Success
Protection configuration applied
GEM Clock CTRL value is : 3
 ATF running on XCZU9EG/silicon v4/RTL5.1 at 0xfffea000, with PMU firmware
NOTICE: BL31: Secure code at 0x0
NOTICE: BL31: Non secure code at 0x8000000
NOTICE: BL31: v1.3(release):f9b244b
NOTICE: BL31: Built : 20:44:11, Jun 5 2018
PMUFW: v0.3

0 Kudos
Moderator
Moderator
92 Views
Registered: ‎03-19-2014

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

I'd advise you port your design to 2018.3.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer wscomm
Observer
76 Views
Registered: ‎07-30-2015

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Thanks for everyone who took a peek.  It turns out the SODIMM module was broken. So the new SODIMMS are compatable with the ZCU102-Z1 Rev 1.0 boards. Had issue with reflashing both 1.0 and 1.1. But all is well.

Thanks again for all the help.

0 Kudos
Observer wscomm
Observer
66 Views
Registered: ‎07-30-2015

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Well ... perhaps not quite solved. We remove a number of new sodemms (MTA4ATF51264HZ-) . Problem came back  ... wondering if its related the double training being done by the bootloader.

 

 

0 Kudos
Moderator
Moderator
51 Views
Registered: ‎03-19-2014

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Have you checked AR 72113  and AR 72110 ?

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer wscomm
Observer
33 Views
Registered: ‎07-30-2015

Re: SODEMM PROJECT: Ported HDF to ZCU102-Z1 rev 1.1 with x16 SODEMMS. Tried moving memory to ZCU102-Z1 Ver 1.0. Halts in FSBL.

Jump to solution

Well we seemed to resolve the issue ... we had to set the configuration to DDR-2400P. Again this is 17.4 ... bottom line trc, tcas and tras had to be tweaked.

 

Thanks again for all the help.

 

 

image.pngCurrent working solution