UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer annamol
Observer
110 Views
Registered: ‎04-18-2017

Zynq ZC702 and SDcard booting issue

Hi,

For ZC702, petalinux based development, we are using SDcard as the boot medium. For running the rootfs from sdcard, using gparted we prepared the boot medium by creating a new partition table as mentioned in https://aerotenna.readme.io/docs/partition-sd-card with a fat32 partition for boot of 200MB and rootfs partition of the remaining size for rootfs. After building the petalinux project, one with normal initramfs file system and one with SDcardrootfs using scp commands, copied the application binaries, BOOT.bin and image.ub to boot partition and after powering on the Zynq board, nothing comes up in gtkterm.Even with a prebuilt image, same thing happens. The terminal stays blank and shows no activity.

The prebuilt image works fine with another SDcard which was not partitioned. The SDcard which was partitioned using gparted,even after deletion of partition table and formatting shows the same response.

Can we use gparted and is the above mentioned partitioning scheme ok?

Or should the steps mentioned in  https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842385/How+to+format+SD+card+for+SD+boot and https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841655/Prepare+Boot+Medium alone be followed. Following the steps in above mentioned links always returns a resource busy error upon syncing and the message partition table will be updated on kernel reboot. Is this ok? Why does this happen?

 

0 Kudos
3 Replies
Moderator
Moderator
71 Views
Registered: ‎03-19-2014

Re: Zynq ZC702 and SDcard booting issue

Per UG585, boot.bin must be in the root of the SD file system

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer annamol
Observer
48 Views
Registered: ‎04-18-2017

Re: Zynq ZC702 and SDcard booting issue

The same steps when followed in one SDcard works without issues, but not in another. is there any dependency like that?(Confusing part is both SD cards were working before and after sometime one stopped working, but neither the card nor the adapter is faulty)

0 Kudos
Moderator
Moderator
35 Views
Registered: ‎03-19-2014

Re: Zynq ZC702 and SDcard booting issue

I would suspect your card formatting and file locations.    Go through your changes in an orderly flow and see what you can find out.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos