UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie erwanlefer2
Newbie
6,449 Views
Registered: ‎04-07-2009

Bitstream generation with microblaze & chipscope

I'm working with Xilinx Platform Studio and I'm trying to learn about Microblaze & Chipscope.

 

First, I redo exactly what is described in the Spartan3ADSP_MB_Example_10_1.pdf document and I inserted a chipscope_plbv46_iba and a chipscope_icon cores in my project. By doing this, I had no error when I generate Bitstream.

 

After that, I made my own project (which is quiet similar) with a chipscope_plbv46_iba and a chipscope_icon cores in my project. And when I generate Bitstream I got the following error for both of the cores:

 

ipscope_icon_0_wrapper/coregen.log
Regenerating IP...
Gathering HDL files for chipscope_icon_0 root...
Creating XST project for chipscope_icon_0...
Creating XST script file for chipscope_icon_0...
Creating XST instantiation file for chipscope_icon_0...
Running XST for chipscope_icon_0...
Not generating a VHDL simulation model
Not generating a Verilog simulation model
Skipping VHDL instantiation template for chipscope_icon_0...
Skipping Verilog instantiation template for chipscope_icon_0...
Finished Regenerating.
Successfully generated chipscope_icon_0.
ERROR:MDT - chipscope_icon_0 (chipscope_icon) - ERROR: Coregen did not generate
   file
   "U:/microblaze/implementation/chipscope_icon_0_wrapper/chipscope_icon_0.ngc"
       while executing
   "error $errMsg"
       (procedure "::hw_chipscope_icon_v1_02_a::icon_generate" line 85)
       invoked from within
   "::hw_chipscope_icon_v1_02_a::icon_generate 73169752"

 

Did somebody get the same error case?

I don't understand what is different in my own project and the Spartan3ADSP_MB_Example_10_1 project, where is the problem with these cores?

 

I really appreciate if someone can give me some help!

 

0 Kudos
5 Replies
Visitor eng.sanchit
Visitor
5,323 Views
Registered: ‎04-24-2011

Re: Bitstream generation with microblaze & chipscope

Hi , i dnt know answer to your question , but can you help me in finding some examples to begin with in microblaze , some basic ones !

Tags (1)
0 Kudos
Highlighted
Newbie anubs123
Newbie
5,210 Views
Registered: ‎03-18-2012

Re: Bitstream generation with microblaze & chipscope

Hello,

 

I am  getting the same error , please share how were u able to solve this problem

 

Thanks in advance 

 

Tags (1)
0 Kudos
Explorer
Explorer
5,198 Views
Registered: ‎06-25-2008

Re: Bitstream generation with microblaze & chipscope

What is on line 85?

0 Kudos
Newbie anubs123
Newbie
5,190 Views
Registered: ‎03-18-2012

Re: Bitstream generation with microblaze & chipscope

Hi,

 

Nothing is visible when we click on the link which comes on this statement .

 

Also this is a problem with elaboration of the netlist platgen is not able to generate the core , which is specified in chipscope.xco file.

 

Since there is no comment or feedback or message from the tool we are unable to have a clue wats wrong , all other IPs including MDMs are getting successfully synthesized but chipscope one.

 

Thanks

Anubhav




 

0 Kudos
Newbie anubs123
Newbie
5,184 Views
Registered: ‎03-18-2012

Re: Bitstream generation with microblaze & chipscope

Please find the logfile

0 Kudos