UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor kiryu69
Visitor
4,325 Views
Registered: ‎01-22-2008

Compact Flash soft reset unable to obtain lock using Sysace

Hello all,

 

I have a custom board with a sysace cf card interface with the following problem:

 

If an inadvertent software reset occurs during a write to the compact flash, the sysace is unable to obtain a lock on the compact flash device.  The only errors that I see are the cf card reports that it is busy and that a write fault exists.  I can clear these with a power cycle on the unit, but for my application this is very undesireable.  I've tried to use the sysace to do a soft reset of the card and I've tried to reset the sysace itself, but nothing seems to work.  Does anyone know of a fix for this problem?

 

Thank you,

 

Nathan

Message Edited by kiryu69 on 04-28-2008 02:57 PM
0 Kudos