UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor manubot
Visitor
19,925 Views
Registered: ‎08-14-2007

EDK, ISE and Platform Studio

Hi!

I'm new over here as I have recently begun to program FPGAs.

I'm trying to get some information about how to program the PowerPC that comes in the virtex4. I found that the EDK package gives support for it. My questions are:

Can I use EDK without having Platform Studio(I have already installed ISE9.2i)?

Requirements in the web are quite ambiguous...

I've tried it, but my ISE version is 9.2i and the last EDK one is 9.1i, so it does not work. So, will be a new version of EDK coming soon or should I install ISE 9.1i ???

Thanks a lot!

Manu
0 Kudos
7 Replies
Explorer
Explorer
19,921 Views
Registered: ‎08-13-2007

Re: EDK, ISE and Platform Studio

1 XPS is just GUI included with EDK
 
2 you can use ISE standalone, but if you want to use EDK you need ISE installation that matches your EDK version
 
3 EDK releases come >1 month after ISE release, so EDK 9.2 will come in some time in future for sure, think in September 2007 (unless it is delayed for some reason)
 
Antti Lukats
0 Kudos
Explorer
Explorer
19,904 Views
Registered: ‎08-14-2007

Re: EDK, ISE and Platform Studio

I (as well as others) currently use ISE 9.2 w/ EDK 9.1 w/ no problems.
0 Kudos
Explorer
Explorer
19,901 Views
Registered: ‎08-13-2007

Re: EDK, ISE and Platform Studio

Hum,
 
this is then I think first time when EDK ISE minor version number can be in mismatch.
with previous major releases this wasnt the case IMHO
 
Antti Lukats
0 Kudos
Xilinx Employee
Xilinx Employee
19,850 Views
Registered: ‎08-01-2007

Re: EDK, ISE and Platform Studio

Manu,

EDK and Platform Studio are synonymous. EDK refers to the whole suite of embedded tools and Platform Studio is the GUI.

You need EDK to program the PowerPC. You must use the same version of the tools, i.e., EDK 9.1i with ISE 9.1i or EDK 9.2i with ISE 9.2i. There is a very good chance that your design could fail if you upgrade to ISE 9.2i. Or, you could wait for the release of EDK 9.2i which should be in a couple of months.

0 Kudos
Visitor manubot
Visitor
19,827 Views
Registered: ‎08-14-2007

Re: EDK, ISE and Platform Studio

Thanks everybody!!!

Manu
0 Kudos
Adventurer
Adventurer
19,769 Views
Registered: ‎08-20-2007

Re: EDK, ISE and Platform Studio

Hello.
I have the same question concerning different versions of EDK and ISE.
Right now from 15th august the New System generator 9.2 is avaliable.
That means if I buy it, I have to buy ISE 9.2. But I'm also use EDK, so I have to buy EDK 9.2 but it is not avaliable right now.
I know that i can wait, but I have to start new project, and I don't want to do it with older versions.
For me it is enought to have 9.1 of ISE and EDK, but the problem that Xilinx allways sends newest version.

So I have two questions:
1. Is it for real, that EDK 9.1 works with ISE 9.2 or it is lie. It is better to hear official version.
2. Or if I buy for example the System Generator or ISE version 9.2 - Can I download somewhere older version, for example 9.1 and use it officially?
I thought there is a warranty possibility to do this. Isn't it?

Thank you.
0 Kudos
Xilinx Employee
Xilinx Employee
19,721 Views
Registered: ‎08-13-2007

Re: EDK, ISE and Platform Studio

#1) I would be surprised if ISE 9.2 works with EDK 9.1. This is not a supported configuration.
http://www.xilinx.com/ise/embedded/edk_download.htm (note coresponding ISE version requirements)
If you can get it work in some cases, please be advised that this is not a tested configuration.
 
#2) If you buy ISE and/or EDK you will be shipped the latest version (which is currently ISE 9.2i and EDK 9.1i). Note that these EDK 9.1i officially requires ISE 9.1.
After purchase, you should contact Xilinx Development Systems Customer Service (not Xilinx Technical Support) and explain that you need Electronic Fulfillment access to ISE 9.1i. for use with EDK 9.1i You should be able to receive electronic download acess for ISE 9.1i
Note that once you purchase ISE and EDK, you should be shipped updates (major/minor releases such as 9.1i/9.2i - not service packs) once they are released while you are in mainatenance (one year from purchase). Please allow some time for DVD mastering, packaging, and shipping. Electronic Fulfillment is usually the quickest way to access a new version once it is publicly released.
 
Cheers,
bt
0 Kudos