UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
2,195 Views
Registered: ‎06-04-2010

FATAL_ERROR:Xst:Portability/export/Port_Main.h error when inserting ChipScope modules.

I'm  using ISE 10.1 and added a ChipScope unit to my design. It has 3 ILA's. During the Implement Design -> Translate step, as soon as it gets to the 2nd ILA it dumps the following to the log:

 

Regenerating IP...
Gathering HDL files for ila_pro_1 root...
Creating XST project for ila_pro_1...
Creating XST script file for ila_pro_1...
Creating XST instantiation file for ila_pro_1...
Running XST for ila_pro_1...
ERROR:sim - Error: XST failed for ila_pro_1.
FATAL_ERROR:Xst:Portability/export/Port_Main.h:143:1.17 - This application
has discovered an exceptional condition from which it cannot recover. 
Process will terminate. For technical support on this issue, please open a
WebCase with this project attached at http://www.xilinx.com/support.Finished Regenerating.
ERROR:sim:57 - Error found during generation

 

Any ideas?  

0 Kudos
1 Reply
Instructor
Instructor
2,186 Views
Registered: ‎08-14-2007

Re: FATAL_ERROR:Xst:Portability/export/Port_Main.h error when inserting ChipScope modules.

I've seen this error in the past, usually when there is a connection problem to a .ngc module

(black box or IP core).  It could happen for example if the connection to the trigger or data

port of the ILA doesn't match the size of the port.  There may be another connection issue,

if the three ILA's are not properly connected to the ICON core.  In any case this particular

message generally indicates a connectivity issue.

 

HTH,

Gabor

-- Gabor
0 Kudos