cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Anonymous
Not applicable
4,731 Views

How to prevent EDK from resynthesizing a custom peripheral.

Jump to solution

Hello.

 

I made a custom peripheral and added it to an EDK project. I am done with it now, so i don't have any of the source files opened for it.

 

I am working on a second one atm but everytime I want to run some test after adjusting the second one, it also keeps synthesizing the first one again! It doesnt do that with all the other library peripherals that come with EDK.

 

Is there some kind of setting or option to prevent the peripheral from being resynthesized? It would save me quite some time.

 

Thanks in advance,

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Historian
Historian
5,569 Views
Registered: ‎02-25-2008

jwp wrote:

Hello.

 

I made a custom peripheral and added it to an EDK project. I am done with it now, so i don't have any of the source files opened for it.

 

I am working on a second one atm but everytime I want to run some test after adjusting the second one, it also keeps synthesizing the first one again! It doesnt do that with all the other library peripherals that come with EDK.

 

Is there some kind of setting or option to prevent the peripheral from being resynthesized? It would save me quite some time.

 

Thanks in advance,


To prevent your custom IP core from being resynthesized every time, you have to modify a line in your MPD file.

 

Look for OPTION ARCH_SUPPORT_MAP = (OTHERS=DEVELOPMENT)

 

and change DEVELOPMENT to PREFERRED. The icon in the Core browser should change to green, too.

 

You might need to re-add the core to the design (delete it and add it back).

 

-a

----------------------------Yes, I do this for a living.

View solution in original post

0 Kudos
3 Replies
Highlighted
Historian
Historian
5,570 Views
Registered: ‎02-25-2008

jwp wrote:

Hello.

 

I made a custom peripheral and added it to an EDK project. I am done with it now, so i don't have any of the source files opened for it.

 

I am working on a second one atm but everytime I want to run some test after adjusting the second one, it also keeps synthesizing the first one again! It doesnt do that with all the other library peripherals that come with EDK.

 

Is there some kind of setting or option to prevent the peripheral from being resynthesized? It would save me quite some time.

 

Thanks in advance,


To prevent your custom IP core from being resynthesized every time, you have to modify a line in your MPD file.

 

Look for OPTION ARCH_SUPPORT_MAP = (OTHERS=DEVELOPMENT)

 

and change DEVELOPMENT to PREFERRED. The icon in the Core browser should change to green, too.

 

You might need to re-add the core to the design (delete it and add it back).

 

-a

----------------------------Yes, I do this for a living.

View solution in original post

0 Kudos
Highlighted
Anonymous
Not applicable
4,684 Views
Thanks Bassman! That did the trick.
0 Kudos
Highlighted
4,251 Views
Registered: ‎04-21-2009

Hi JWp,

 

 

 Hey regarding the problem with your RS232 not printing anything it happens as nothing is getting synthesized in your  design. You can cross check this in the file , <your_design> _map.mrp file in the implementation folder.

This is surely due to the C_CLk_GEN problems in 10.1 SP3 of EDk.

The post regarding setting it to 1 does not  actually help to solve the problem.

Were you able to solve it by any other manner ,, If so please do tell me ,, Im facing similar problems in it .. 

 

Thanks and regards,

Hitesh

 

 

 

0 Kudos