We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Visitor edwarwl
Registered: ‎07-10-2008

Improving EDK Simulation Speed

I would like to find some way to speed up my behavioral simulation time for a design in EDK. I am using ModelSim SE for the simulations.


I would like to be able to use a larger timestep (maybe 100ps instead of ps), but the UNISIM library throws an error when I attempt to simulate with anything besides 1ps resolution. Here is that error message:


# ** Fatal: (SIGFPE) Floating point exception.
# Time: 0 ps Iteration: 0 Process: /system/clock_generator_0/clock_generator_0/using_pll0/pll0_inst/pll_inst/using_pll_adv/pll_adv_inst/clock_period_update_p File: C:/Xilinx/10.1/ISE/vhdl/src/unisims/unisim_VITAL.vhd
# Fatal error in Process clock_period_update_p at C:/Xilinx/10.1/ISE/vhdl/src/unisims/unisim_VITAL.vhd line 168422
# HDL call sequence:
# Stopped at C:/Xilinx/10.1/ISE/vhdl/src/unisims/unisim_VITAL.vhd 168422 Process clock_period_update_p


The erroring line in unisim_VITAL.vhd is as follows:


period_vco_rm_tmp1 := period_fb_tmp / 1 ps;


I guess it may just be the nature of the beast, but a 300ms simulation takes close to 18 hours to complete on my machine. Is there any way to shorten the simulation time?

0 Kudos
1 Reply
Observer drgrid
Registered: ‎11-03-2009

Re: Improving EDK Simulation Speed

I am afraid that it may be the nature of the beast.  At least you have ModelSim SE; I have been working with PE so

if I had the money I could buy better performance.  But you don't have that option.


You can see a very slight improvement if simulate in batch mode, rather than with the GUI.  But you are probably

already doing that.



0 Kudos