cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer
Observer
5,111 Views
Registered: ‎07-08-2010

LWIP error in EDK12.1

Jump to solution

 hi..

i m using Virtex-4 FX12 minimodule and i m using EDK12.1 for development..

i m including LWIP library (through software platform settings) in my application....while compliling the project

it gives error

(undefined reference to "lwip_write")

and same error for all lwip funcions which are used in application..

 

this seems that it is problem of including the lwip library but i hav includes lwip library in

software platform settings---->os and library settings

here i have checked lwip in checkbox

 

in the application code i have also included the header files

#include "lwip/sockets.h "

 

but if i use edk10.1+ sp3 and make an application (using lwip)over there ..same type of application complies and run without any problem....

 

now i m stuck at this stage....i dont  understand how to fix it...

 

can any body help me regarding this problem..

 

 

thanks.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
6,385 Views
Registered: ‎08-02-2007

Re: LWIP error in EDK12.1

Jump to solution

Hi,

 

Right Click over the application.

 

Go to Set Compiler options.

 

Go to Path and Options tab.

 

Make sure the Libraries to link as shown in compiler_settings.JPG attached.

 

Thnx

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

compiler_settings.JPG
0 Kudos
5 Replies
Highlighted
Moderator
Moderator
5,072 Views
Registered: ‎08-25-2009

Re: LWIP error in EDK12.1

Jump to solution

Did you check the api_mode for LWIP to SOCKET_API? By default it;s RAW_API mode.

"Don't forget to reply, kudo and accept as solution."
0 Kudos
Highlighted
Observer
Observer
5,012 Views
Registered: ‎07-08-2010

Re: LWIP error in EDK12.1

Jump to solution

ya i have checked the API mode it is SOCKET_API

0 Kudos
Visitor
Visitor
5,003 Views
Registered: ‎03-23-2008

Re: LWIP error in EDK12.1

Jump to solution

can you tell how you set the software plateform settings for lwip

 

sujeet

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
6,386 Views
Registered: ‎08-02-2007

Re: LWIP error in EDK12.1

Jump to solution

Hi,

 

Right Click over the application.

 

Go to Set Compiler options.

 

Go to Path and Options tab.

 

Make sure the Libraries to link as shown in compiler_settings.JPG attached.

 

Thnx

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

compiler_settings.JPG
0 Kudos
Highlighted
Observer
Observer
4,899 Views
Registered: ‎07-08-2010

Re: LWIP error in EDK12.1

Jump to solution

thanks...

i was not  doing complier settings options thats why libraries were not getting linked..

0 Kudos