UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer claudio_fidia
Observer
357 Views
Registered: ‎11-07-2017

Linker error when add custom library

Hi

I have a problem when I add a library to my zynq-7000 project with SDK 2018.2.

When compiling the project I get a library not found error and the problem is due to a -l

prefix added by the SDK tool to library list in linker command line..

I have added the library in my project property (C/C++ General->Paths and Symbols->Library).

This is an example of the incorrect string:

-l-Wl,--start-group,-lxil,-lfreeRtos,-lmylib,-lgcc,-lc,-lstdc++,--end-group

I red a similar issue in AR #50482 but still not resolved in 2018.2.

Thank you

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
331 Views
Registered: ‎12-21-2016

Re: Linker error when add custom library

Hi,

Please add your library at the following location and let us know whether this works for you. Please see the screenshot for details

 

Regards,
Raju
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.

Untitled.png
0 Kudos