UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie orlando.lg
Newbie
3,704 Views
Registered: ‎05-11-2010

ML507 MMU implementation error

Hi,

...I use ISE/EDK 11.3, by BSB I configured my ML507 system, microblaze, and some others peripherals...Implementation (bitstream ) and everything is OK....
but, now I want the same but with MMU (for some Linux support)...and after MMU changes on "microblaze configure IP"....
 
In my EDK MMU bitstream process I had 2 error :
 
1st- bitstream error:
 
        ERROR: 1 constraint not met.
 
        PAR could not meet all timing constraints. A bitstream will not be generated.
 
        To disable the PAR timing check:
 
        1> Disable the "Treat timing closure failure as error" option from the Project Options dialog in XPS.
 
        OR
 
        2> Type following at the XPS prompt:
       XPS% xset enable_par_timing_error 0

       make: *** [implementation/system.bit] Error 1
 
 
Then I disabled "Treat timing closure failure as error" option from the Project Options dialog in XPS.
 
And bitstream finished successfully (..???...)
 
2nd- Download error :
 
 Some problem of size of dlmb_ctr and ilmb_ctr...Then I increased dlmb_ctr and ilmb_ctr from 8 K (default) to 256 K...
 
I set MMU as ML505 reference's, also with "protection" mode instead of "virtual"....(both really), I checked  C_use_MMU = 3
but nothings seems to solve the problem....The point is I do not want this error...'cause my Linux start process freezes, so maybe after MMU adjust, some changes must be done in UCF files or somethings...
...any clue ?
Thanks.
0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
3,675 Views
Registered: ‎11-06-2007

Re: ML507 MMU implementation error

This message was moved from Timing Analysis.

 

You should work to resolve the timing issue in the design as this may result in the incorrect behaviour of hardware. Turning off the option "Treat timing closure failure as error" will allow the tools to complete but this only workarounds the timing issue.

 

Can someone with EDK knowledge please comment on issue 2.

0 Kudos
Xilinx Employee
Xilinx Employee
3,667 Views
Registered: ‎08-06-2007

Re: ML507 MMU implementation error

Hi,

 

On the 2nd issue, did you increase the size in the linker script or in the actual hardware.

They must both match each other and you can't just increase the size of memory in the linker script without increasing the same amount of memory in hardware.

I would also just increase the memory in step of 2x since large LMB memory has a negative impact on the frequency.

 

Göran

0 Kudos
Newbie landrove
Newbie
3,642 Views
Registered: ‎05-26-2010

Re: ML507 MMU implementation error

I increased both ( dlmb_ctrl and ilmb_ctrl ) to 256 K.....

 

...In linkerScript properties I see :

 

-ilmb_ctrl_dlmb_ctrl ... 256K Leght

 

-DDR2_SDRAM_C_MPMC_BASEDDR......262144K Leght

 

-FLASH_C_MEM0_BASEADDR.................32768K Leght

 

When I implement bitstreamno error appear related with mb_crl, so, I assumed it passed....

 

...I know I have to get into Timing Analyzer and timing constraint stuffs, the point is that  "system.ucf" constraint was generated along with BSB process....and MMU configuration is carried out after it...and I posted it hoping somebody  had faced before with same "system.ucf" MMU adjunting trouble.

 

Attached is my system.ucf...maybe it will gives a clue for somebody

0 Kudos