UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant heiyux
Participant
306 Views
Registered: ‎02-19-2009

Problem - Link command automatically add a "-l" prefix before lib values after modifying library in SDK 2017.4

Hi there,

 

   I'm using SDK 2017.4 on windows 10.

   I generate a "helloworld" project on my hw_platform, it works fine.

   But when I modify the library values in the project properties, something like: "-Wl,--start-group,-lxil,-lgcc,-lc,--end-group"(default) to "-Wl,--start-group,-lxil,-lgcc,-lc,--end-group,-lHDMI_ZynqLib"(add a lib name, I have also copied my Lib file into the Lib path), the project build with error:

       ld.exe: cannot find -l-Wl,--start-group,-lxil,-lgcc,-lc,--end-group,-lHDMI_ZynqLib

then I delete the value I added, recover the lib setting to the default, the project still build with error:

       ld.exe: cannot find -l-Wl,--start-group,-lxil,-lgcc,-lc,--end-group

 

   I compared the Link command in the project with the original success one. I found the two commands was different:

       original success one : "......../src/platform.o -Wl,--start-group,-lxil,-lgcc,-lc,--end-group"

       after lib modifying one : "......../src/platform.o -l-Wl,--start-group,-lxil,-lgcc,-lc,--end-group"

 

   After I modified the Library setting, even when I recovered them, the Link Command add a lib value prefix "-l", and results Link error.

 

   I don't know why, and can't fix it.

 

Need help.

Thank you everyone!

Snipaste_2018-07-22_10-16-53.png

 

Day

0 Kudos
1 Reply
Moderator
Moderator
257 Views
Registered: ‎10-06-2016

Re: Problem - Link command automatically add a "-l" prefix before lib values after modifying library in SDK 2017.4

Hi @heiyux,

 

Are you still facing this issue? I was not able to reproduce it on my end. It seems that something a library is added with empty string so the -l is added to the configuration...

 

Regards

Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos