UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
1,939 Views
Registered: ‎09-28-2012

Problem of ISIM simulation of microblaze project

Jump to solution

Hi,

I have a SP605 board with ISE 14.4 installed on Windows 7 OS. I have built a small Microblaze project. It is a xilkernel project, which blinks LED plus UART xilprintf. In fact, it is modified from the xilkernal example project. It can be downloaded to SP605 board and runs OK.

 

I want to go through ISIM simulation. I have added .elf to ISE project navigator project. I associate the .elf with simulation project and bootloop to the implementation project. When ISIM run the simulation, I notice that the Microblaze instruction address goes from (at 1.2 uS) 00000000,00000004,00000008, 00000000c, 00000050, 00000054,00000058,0000005c.......000001f8. Then, it cycles 000001e4,00000001e8,0000001ec, 000001f0,000001f4,000001f8,000001e4,0000001e8......

It cycles even for several mS. I don't think it runs my application. It runs bootloop? What is wrong with the simulation?

 

Thanks,

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Explorer
Explorer
2,503 Views
Registered: ‎09-28-2012

Re: Problem of ISIM simulation of microblaze project

Jump to solution

Excuse me. I forgot th say that I use 64 KB block ram for code, without using external DRAM. I want the system simple enough to run the ISIM simulation. But it does not work. Could you help me? thanks

0 Kudos
1 Reply
Highlighted
Explorer
Explorer
2,504 Views
Registered: ‎09-28-2012

Re: Problem of ISIM simulation of microblaze project

Jump to solution

Excuse me. I forgot th say that I use 64 KB block ram for code, without using external DRAM. I want the system simple enough to run the ISIM simulation. But it does not work. Could you help me? thanks

0 Kudos