UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor smee204
Visitor
2,028 Views
Registered: ‎02-06-2012

Processor not started/reset after bit download

After I download a download.bit file onto a ppc440 fpga using the ml507 dev board the embedded elf file does not run.

I am creating a bit file in EDK and then adding an elf file into bram with a boot vector at 0xfffffffc. After the bit stream has been downloaded the application does not run. If I check the processor registers and pc using jtag they all contain random uninitialised data. If I then download the elf file using jtag it looks like the processor is initialised as the pc register is set to 0xfffffffc and the other registers are set to an initialised state.

I am currently using EDK 13.4, I am sure this used to work in the past when I was using 11.1.

 

I have tried setting the startup clock to CCLK and JTAGCLK. I have also tried booting from flash and the fpga gets configured but the processor never starts.

 

Any idea what is wrong? Or how to debug this further?

 

 

Tags (3)
0 Kudos
1 Reply
Participant schneemann79
Participant
2,015 Views
Registered: ‎05-02-2009

Re: Processor not started/reset after bit download

hey,

 

i do not know for sure what your problem might be but please have a look at my post a couple of days ago.

 

http://forums.xilinx.com/t5/EDK-and-Platform-Studio/PPC-system-not-working-in-13-2-amp-13-3/td-p/190476

 

SDK/XMD/PPC interaction is an annoying issue which nobody takes care of. SOme versions of SDK seem not to be able to interpret an elf entry point of 0xfffffffc correctly.  do you have your software part completely in bram or just the bootloop/boot sections which then branch to code in external DRAM? Behaviour might also be different when your HW uses interrups.

 

you can alternatively use the dow command in your xmd console and then debug your memory content with commands like mrd, srrd, stp and con. use "help running" for a complete list. Also try to press your reset button on the board after downloading to see if it helps.

0 Kudos