cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
joe306
Scholar
Scholar
329 Views
Registered: ‎12-07-2018

Program Flash Fail

Jump to solution

Hello, I have a custom board that is designed to boot from QSPI or NAND x8 Flash. I am able to program the QSPI Boot memory and am able to power down and power up and it does run the code on the PL-side and the code on the PS-side. I'm simply toggling an LEDS. The problem is when I try to program the NAND Flash memory. I get the following error popup

flash_fail.jpgflash_fail_errors.jpg

 

Any ideas what this error could point to in my hardware?

Respectfully,

Joe

0 Kudos
1 Solution

Accepted Solutions
joe306
Scholar
Scholar
306 Views
Registered: ‎12-07-2018

I think that my problem is that when I booted the FPGA, my boot pin settings was for NAND and not JTAG. Therefore the FPGA could not properly boot. This was a mistake I think. So when I ran the Program Flash Utility I got the error.

I think one should set the Boot mode pins to JTAG, power on the FPGA and then program the NAND Flash. After it has completed, power down, change the Boot mode pins to NAND and then boot up.

Does that sound reasonable?

View solution in original post

0 Kudos
2 Replies
joe306
Scholar
Scholar
307 Views
Registered: ‎12-07-2018

I think that my problem is that when I booted the FPGA, my boot pin settings was for NAND and not JTAG. Therefore the FPGA could not properly boot. This was a mistake I think. So when I ran the Program Flash Utility I got the error.

I think one should set the Boot mode pins to JTAG, power on the FPGA and then program the NAND Flash. After it has completed, power down, change the Boot mode pins to NAND and then boot up.

Does that sound reasonable?

View solution in original post

0 Kudos
joe306
Scholar
Scholar
242 Views
Registered: ‎12-07-2018

I'm closing this post. I'm still having trouble booting from QSPI but I will open a Support Ticket. If I find the solution I will post it.

0 Kudos