UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
9,763 Views
Registered: ‎09-19-2014

SDK 2015.4 Tcl script setting up application to use BSP

I am using SDK 2015.4, and have found the Tcl script and HSI commands specified in this useful document:

http://www.xilinx.com/support/documentation/sw_manuals/xilinx2015_4/ug1138-generating-basic-software-platforms.pdf

There are some good examples in the latter part of Chapter 4.

 

If I manually create a Zynq FSBL application in the GUI SDK, I can choose on the new application dialog between "create new BSP" or "use existing BSP". I want to be able to specify to use an existing BSP.

 

In the Tcl script, I have:

hsi::open_hw_design $hw_path/system.hdf
hsi::create_sw_design -proc ps7_cortexa9_0 -os standalone BSP

hsi::generate_bsp -dir $bsp_path -compile

hsi::create_sw_design -proc ps7_cortexa9_0 -os standalone -app zynq_fsbl fsbl

hsi::generate_app -dir $fsbl_path -compile

It ends up generating the BSP at the "generate_bsp" command, but then the subsequent "create_sw_design" command to make the application does not seem to use the current sw design, but it ends up regenerating its own BSP. So it is generated twice. I don't want that.

 

How do I specify  within either "create_sw_design" command or "generate_app" command to use a specific existing BSP?

Tags (5)
0 Kudos
2 Replies
Scholar sampatd
Scholar
9,742 Views
Registered: ‎09-05-2011

Re: SDK 2015.4 Tcl script setting up application to use BSP

The reason zynq fsbl creates its own BSP is that the Zynq FSBL BSP requires that the xilffs and xilrsa libraries are present.

Please check the AR below:
http://www.xilinx.com/support/answers/64200.html

0 Kudos
Adventurer
Adventurer
9,729 Views
Registered: ‎09-19-2014

Re: SDK 2015.4 Tcl script setting up application to use BSP

Yes, FSBL does require those libraries, but unfortunately, no, that's not the reason.

 

I did have the following as the actual script I was running. I just abstracted away those details that I thought weren't relevant.

 

hsi::open_hw_design $hw_path/system.hdf
hsi::create_sw_design -proc ps7_cortexa9_0 -os standalone BSP

hsi::add_library xilffs
hsi::add_library xilrsa
hsi::set_property CONFIG.stdin ps7_uart_1 [hsi::get_os]
hsi::set_property CONFIG.stdout ps7_uart_1 [hsi::get_os]

hsi::generate_bsp -dir $bsp_path -compile

hsi::create_sw_design -proc ps7_cortexa9_0 -os standalone -app zynq_fsbl fsbl

hsi::generate_app -dir $fsbl_path -compile

 

"generate_app" still creates its own BSP.

 

The linked AR is about using the "sdk" commands in XSCT, but I am using just HSI commands. I did see that:

"However, the FSBL app requires the xilffs and xilrsa libraries in the BSP, and BSP generation will not have these by default. 

To work around this, you just need to create the Zynq FSBL app as this will generate the BSP automatically."

 

I don't believe that pure HSI commands should require a workaround, since you can actually specify the libraries directly, as I have.

0 Kudos