UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer chewenjie27205
Observer
1,362 Views
Registered: ‎08-06-2018

SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi everyone,

 

I was using SDK 2018.2 to compile a linux application for the Zybo board. I specified the "ARM v7 linux gcc assembler/compiler/linker" as 'arm-xilinx-gnueabi-gcc' in the 'C/C++ Build --> Settings'. But the build console returned the following error message:

 

'Invoking: ARM v7 Linux gcc compiler'
arm-xilinx-gnueabi-gcc -Wall -O0 -g3 -c -fmessage-length=0 -MT"SDK/common.o" -MMD -MP -MF"SDK/common.d" -MT"SDK/common.o" -o "SDK/common.o" "F:/FPGAs/Zybo/SDK/common.c"
'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command,
operable program or batch file.
make: *** [SDK/common.o] Error 1

 

Is this because the new version 2018.2 SDK excludes the 'arm-xilinx-gnueabi-gcc' compiler? How could I fix this and get my C program linux application compiled and running on the Zybo board? Thanks.

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,292 Views
Registered: ‎10-06-2016

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi @chewenjie27205,

 

It's clear that the issues seems to be related to the host machine and some configuration/setting... that is having impact on this but don't think is generic to Windows 10 OS by itself.

 

Could you additionally test calling Make from command line (you need to run it within the Debug folder in the top Makefile) and also running yourself the linker command?

 

Regards

Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
8 Replies
Moderator
Moderator
1,295 Views
Registered: ‎10-06-2016

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution
Hi @chewenjie27205,

You are right arm-xilinx-gnueabi-gcc is being removed from the SDK toolchains, but it is standalone application toolchain (CodeSourcery GCC).

If you need to compile a Linux application for ARM v7 you need to use arm-linux-gnueabihf-gcc.

Regards
Ibai

Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Observer chewenjie27205
Observer
1,284 Views
Registered: ‎08-06-2018

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi Ibai,

 

Thanks for the reply.

 

Actually I got an error even using arm-linux-gnueabihf-gcc as the compiler for 2018.1 SDK to compile a simple linux application (a hello world program). The 2018.1 SDK is installed on a Windows 10 Enterprise OS. The error message is as below:

 

'Building file: ../src/helloworld.c'
'Invoking: ARM v7 Linux gcc compiler'
arm-linux-gnueabihf-gcc -Wall -O0 -g3 -c -fmessage-length=0 -MT"src/helloworld.o" -MMD -MP -MF"src/helloworld.d" -MT"src/helloworld.o" -o "src/helloworld.o" "../src/helloworld.c"
arm-linux-gnueabihf-gcc: error: CreateProcess: No such file or directory
make: *** [src/helloworld.o] Error 1

 

Do you have any idea of how to solve this error? Is it because the 2018.1 SDK is not supporting the Windows 10 Enterprise OS? Please let me know your thoughts, thanks.

 

Regards,

Wenjie 

0 Kudos
Moderator
Moderator
1,272 Views
Registered: ‎10-06-2016

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi @chewenjie27205

 

Not sure if the issue is related to your OS version, the error message seems to point more to the fact of not being able to reach the selected toolchain (maybe not installed properly).

 

As a quick test you can try to check if it is installed properly using the XSCT window within the SDK GUI. Check the toolchain version with the following command.

$ arm-linux-gnueabihf-gcc -v
Using built-in specs.
COLLECT_GCC=arm-linux-gnueabihf-gcc
COLLECT_LTO_WRAPPER=/proj/xbuilds/released/2018.2/GA/2018.2_0614_1954/installs/lin64/SDK/2018.2/gnu/aarch32/lin/gcc-arm-linux-gnueabi/bin/../libexec/gcc/arm-linux-gnueabihf/7.2.1/lto-wrapper
Target: arm-linux-gnueabihf
Configured with: /proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/snapshots//gcc-linaro-7.2-2017.11-rc1/configure SHELL=/bin/sh --with-bugurl=https://bugs.linaro.org --with-mpc=/proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/builds/destdir/x86_64-unknown-linux-gnu --with-mpfr=/proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/builds/destdir/x86_64-unknown-linux-gnu --with-gmp=/proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/builds/destdir/x86_64-unknown-linux-gnu --with-gnu-as --with-gnu-ld --disable-libstdcxx-pch --disable-libmudflap --with-cloog=no --with-ppl=no --with-isl=no --disable-nls --enable-c99 --enable-gnu-indirect-function --disable-multilib --with-tune=cortex-a9 --with-arch=armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-mode=arm --disable-multilib --enable-multiarch CFLAGS=-O2 CXXFLAGS=-O2 --disable-silent-rules --enable-libquadmath --enable-libg2c --enable-symvers=gnu --enable-libstdcxx-pch --enable-libssp --disable-libmudflap --enable-checking=release --enable-cheaders=c_global --enable-poison-system-directories --enable-clocale=generic --enable-shared --enable-threads=posix --disable-multilib --enable-c99 --without-local-prefix --enable-lto --disable-bootstrap --with-linker-hash-style=gnu --with-ppl=no --with-cloog=no --without-isl --enable-nls --enable-__cxa_atexit --with-build-sysroot=/proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/builds/destdir/x86_64-unknown-linux-gnu/arm-linux-gnueabihf/libc --enable-plugins --enable-linker-build-id --enable-long-long --enable-shared --with-sysroot=/proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/builds/destdir/x86_64-unknown-linux-gnu/arm-linux-gnueabihf/libc --enable-languages=c,c++,lto --enable-checking=yes --disable-bootstrap --with-bugurl=https://bugs.linaro.org --build=x86_64-unknown-linux-gnu --host=x86_64-unknown-linux-gnu --target=arm-linux-gnueabihf --prefix=/proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/builds/destdir/x86_64-unknown-linux-gnu
Thread model: posix                                                                                                                                                                                                                           
gcc version 7.2.1 20171011 (Linaro GCC 7.2-2017.11-rc1) 

Regards

Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Observer chewenjie27205
Observer
1,262 Views
Registered: ‎08-06-2018

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi Ibai, 

 

I tried with your recommended commands in XSCT, and I got the following message:

 

=====================================================

xsct% arm-linux-gnueabihf-gcc -v

 

WARNING: [Common 17-259] Unknown Tcl command 'arm-linux-gnueabihf-gcc -v' sending command to the OS shell for execution. It is recommended to use 'exec' to send the command to the OS shell.
Using built-in specs.
COLLECT_GCC=C:\ProgramData\Xilinx\SDK\2018.1\gnu\aarch32\nt\gcc-arm-linux-gnueabi\bin\arm-linux-gnueabihf-gcc.EXE
Target: arm-linux-gnueabihf

 

Configured with: /proj/esdt_sdk/gnu_abe/ABE/builds/lin/arm/arm-linux/snapshots//gcc-linaro-7.2-2017.11-rc1/configure SHELL=/bin/sh --with-bugurl=https://bugs.linaro.org --with-mpc=/proj/esdt_sdk/gnu_abe/ABE/builds/win/arm/arm-linux/builds/destdir/x86_64-w64-mingw32 --with-mpfr=/proj/esdt_sdk/gnu_abe/ABE/builds/win/arm/arm-linux/builds/destdir/x86_64-w64-mingw32 --with-gmp=/proj/esdt_sdk/gnu_abe/ABE/builds/win/arm/arm-linux/builds/destdir/x86_64-w64-mingw32 --with-gnu-as --with-gnu-ld --disable-libstdcxx-pch --disable-libmudflap --with-cloog=no --with-ppl=no --with-isl=no --disable-nls --enable-c99 --enable-gnu-indirect-function --disable-multilib --with-tune=cortex-a9 --with-arch=armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-mode=arm --disable-multilib --enable-multiarch CFLAGS=-O2 CXXFLAGS=-O2 --disable-silent-rules --enable-libquadmath --enable-libg2c --enable-symvers=gnu --enable-libstdcxx-pch --enable-libssp --disable-libmudflap --enable-checking=release --enable-cheaders=c_global --enable-poison-system-directories --enable-clocale=generic --enable-shared --enable-threads=posix --disable-multilib --enable-c99 --without-local-prefix --enable-lto --disable-bootstrap --with-linker-hash-style=gnu --with-ppl=no --with-cloog=no --without-isl --enable-nls --enable-__cxa_atexit --with-build-sysroot=/proj/esdt_sdk/gnu_abe/ABE/builds/win/arm/arm-linux/builds/destdir/x86_64-w64-mingw32/arm-linux-gnueabihf/libc --enable-plugins --enable-linker-build-id --enable-long-long --enable-shared --with-sysroot=/proj/esdt_sdk/gnu_abe/ABE/builds/win/arm/arm-linux/builds/destdir/x86_64-w64-mingw32/arm-linux-gnueabihf/libc --enable-languages=c,c++,lto --enable-checking=yes --disable-bootstrap --with-bugurl=https://bugs.linaro.org --build=x86_64-unknown-linux-gnu --host=x86_64-w64-mingw32 --target=arm-linux-gnueabihf --prefix=/proj/esdt_sdk/gnu_abe/ABE/builds/win/arm/arm-linux/builds/destdir/x86_64-w64-mingw32

 

Thread model: posix
gcc version 7.2.1 20171011 (Linaro GCC 7.2-2017.11-rc1)

=====================================================

 

Looks like it is printing the version information. Do you see anything problematic? Thanks!

 

Regards,

Wenjie

 

 

0 Kudos
Moderator
Moderator
1,249 Views
Registered: ‎10-06-2016

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi @chewenjie27205

 

It seems that your toolchain is installed fine so the problem must be somewhere else. Do you have the antivirus enabled? I saw in the past some issues accessing files (in this case the linker needs to get the .o files to generate the ELF file) from the SDK, so might be good exercise to disable it just for compilation test.

 

Another test might be to compile the application using make command from the XSCT command line with the SDK GUI closed, in order to see if the Eclipse framework have some impact as well.

 

Regards

Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Observer chewenjie27205
Observer
1,223 Views
Registered: ‎08-06-2018

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi Ibai,

 

We tried to disable the antivirus and even the firewall but the error was still there.

 

Also I used XSCT to create the project and application, we still got the same error message as below after we tried to compile:

 

xsct% createapp -name hello_world_XSCT -app {Linux Hello World} -proc ps7_cortexa9 -hwproject hw_xsct -os linux
Starting xsdk.bat. This could take few seconds... done
Application project 'hello_world_XSCT' created successfully.
xsct% projects -build
Building '/RemoteSystemsTempFiles'
Building '/design_1_wrapper_hw_platform_0'
Building '/hello_world_XSCT'
11:53:37 **** Build of configuration Debug for project hello_world_XSCT ****
make all
'Building file: ../src/helloworld.c'
'Invoking: ARM v7 Linux gcc compiler'
arm-linux-gnueabihf-gcc -Wall -O0 -g3 -c -fmessage-length=0 -MT"src/helloworld.o" -MMD -MP -MF"src/helloworld.d" -MT"src/helloworld.o" -o "src/helloworld.o" "../src/helloworld.c"
arm-linux-gnueabihf-gcc: error: CreateProcess: No such file or directory
make: *** [src/helloworld.o] Error 1

 

I am wondering whether this compilation error exists for all the Windows 10 OS. We tried to install SDK 2018.2 and the error message was still there. Do you have any thoughts? Thanks!

 

Regards,

Wenjie

0 Kudos
Moderator
Moderator
1,293 Views
Registered: ‎10-06-2016

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi @chewenjie27205,

 

It's clear that the issues seems to be related to the host machine and some configuration/setting... that is having impact on this but don't think is generic to Windows 10 OS by itself.

 

Could you additionally test calling Make from command line (you need to run it within the Debug folder in the top Makefile) and also running yourself the linker command?

 

Regards

Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Observer chewenjie27205
Observer
1,164 Views
Registered: ‎08-06-2018

Re: SDK 2018.2 'arm-xilinx-gnueabi-gcc' is not recognized as an internal or external command, operable program or batch file.

Jump to solution

Hi Ibai,

 

Thanks for pointing out the "settings". Actually I checked the "system variables" of the host machine and found there is a variable named "GCC_EXEC_PREFIX", I removed this variable and restarted SDK and the error was gone. Looks like it is because of the environmental settings of the gcc.

 

Thanks for your suggestions!

 

Regards,

Wenjie

0 Kudos