cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
11,042 Views
Registered: ‎12-24-2009

SDK not rendering screen correctly in Linux

Jump to solution

I had been using 11.[1-3] on Ubuntu 8.04 successfully since May.

 

Motherboard failure --> fresh install of Ubuntu 9.10.

 

Now when I setup a fresh install of ISE 11.4.  Everything works except, whenever I open SDK, all the text files do not render and some of the other panes do not render correctly as well.  Just a lot of grey...

 

I run from the command line with -debug option and no errors show up. 

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
12,952 Views
Registered: ‎12-24-2009

h_corey,

 

I think I figured it out. Looks like theres an issue with old GTK applications running with the latest release of GTK. Buttons and other wigets (like text windows) are all included. I created a shell script called "xps_custom" in the Xilinx/EDK/bin/lin directory and now I just execute that:

 

 

 

#!/bin/sh export GDK_NATIVE_WINDOWS=1 <path_to_install>/Xilinx/11.1/EDK/bin/lin/xps_sdk

 

Now it looks normal and I can edit text and the buttons depress properly.

 

 

Here's a more detailed description of what this does if you're curious.

 

 

http://blogs.gurulabs.com/dax/2009/10/what-gdk-native.html

 

 

I like keeping it in a shell script so other applications are not corrupted if they require the latest GTK libraries, although if you have other older-ecplise tools, you could easily put the export in your .bashrc resource file as well.

 

 

 

Hope this helps,

Mike

View solution in original post

8 Replies
Highlighted
11,029 Views
Registered: ‎12-24-2009

h_corey,

 

I'm having the exact same problem with a new upgrade to 9.10 Ubuntu and 11.4 ISE/EDK/SDK. XPS and JTAG are working fantastic (after a couple hours of hacking the driver permissions) with hardware design/bitstream updates, but software development right now is dead action. I've been trying to find if there's permission issues with the eclipse core files - maybe in the installation directory.

 

I noticed that the default .metadata folder and some files underneath were being locked out as root when the workspace was initialized and I was getting permission errors when I tried to change the syntax highlighting. I did a chmod/chown on all the files in the .metadata directory but it didn't seem to change the greyed out behavior - however, my syntax highlighting changes are not causing error after the permissions and ownership changes.

 

I'm used to eclipse but this is a new one. Another issue I seem to be having (and not sure if this is Xilinx-related or an Ubuntu issue), is that buttons over java-based apps are not fully depressing with the mouse. Very strange. In SDK preferences, I have to highlight and select with the mouse about 50% of the time and then while the button looks highlighted, I have to hit the Enter key to fully depress the button.

 

I'll post here again if I make any progress...

0 Kudos
Highlighted
Contributor
Contributor
11,007 Views
Registered: ‎12-24-2009

I am now trying to run the sdk with ubuntu's 'sun java 6' in hopes that would shed some light... 

 

--Update: nope nothing there 

Message Edited by h_corey on 12-25-2009 10:01 PM
0 Kudos
Highlighted
12,953 Views
Registered: ‎12-24-2009

h_corey,

 

I think I figured it out. Looks like theres an issue with old GTK applications running with the latest release of GTK. Buttons and other wigets (like text windows) are all included. I created a shell script called "xps_custom" in the Xilinx/EDK/bin/lin directory and now I just execute that:

 

 

 

#!/bin/sh export GDK_NATIVE_WINDOWS=1 <path_to_install>/Xilinx/11.1/EDK/bin/lin/xps_sdk

 

Now it looks normal and I can edit text and the buttons depress properly.

 

 

Here's a more detailed description of what this does if you're curious.

 

 

http://blogs.gurulabs.com/dax/2009/10/what-gdk-native.html

 

 

I like keeping it in a shell script so other applications are not corrupted if they require the latest GTK libraries, although if you have other older-ecplise tools, you could easily put the export in your .bashrc resource file as well.

 

 

 

Hope this helps,

Mike

View solution in original post

Highlighted
Contributor
Contributor
10,964 Views
Registered: ‎12-24-2009
Bingo, you rock.
0 Kudos
Highlighted
Observer
Observer
10,786 Views
Registered: ‎06-02-2008

Hi Mike,

 

Thank you for your tip. You have solved my problem under Fedora 12....

 

Cheers,

 

Pat.

0 Kudos
Highlighted
Newbie
Newbie
10,725 Views
Registered: ‎01-29-2010

Thanks for the solution to this problem. It worked for me. I'm using the Xilinx 11.4 tools on SuSE 11.2. Woo hoo!

 

Kudos to you.

 

Mitch Burghart

Portland State University

0 Kudos
Highlighted
Contributor
Contributor
10,323 Views
Registered: ‎11-24-2009

Kudos!

 

:smileyvery-happy:

 

Cheers.

0 Kudos
Highlighted
Visitor
Visitor
9,447 Views
Registered: ‎10-13-2008

Thanks, this also fixed my issue with 11.4 on Ubuntu 9.10

0 Kudos