cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
6,426 Views
Registered: ‎05-26-2014

Type fatal error: lwip/err.h: No such file or directory

Jump to solution

Hello,

        I'm getting this error when i try to generate lwIP server Application project. I m using SDK 14.7 Tool.

     

       I have just gone through the other similar issue, and varied that lwIP lib is include or not. And I can see that the lib is icluded in BSP.

       

     Can anyone please help me what should I do

    This error I'm getting

Screenshot.jpg
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Scholar
Scholar
8,832 Views
Registered: ‎09-05-2011

I tried to create a new SDK workspace using your hardware platform (Ethernet_hw_platform), but i encountered the following error:

intc_lwip.png

 

From the above error, it looks like you have not enabled the ethernetlite interrupts in your hardware project. Please note that this is a must when trying to use the lwip stack.

must.png

 

You may want to refer to the hardware project as mentioned in xapp1026

http://www.xilinx.com/support/documentation/application_notes/xapp1026.pdf 

 

Can you please check your hardware project if the interrupts are connected properly?

View solution in original post

0 Kudos
4 Replies
Highlighted
Scholar
Scholar
6,415 Views
Registered: ‎09-05-2011
Can you attach the SDK workspace?
0 Kudos
Highlighted
Contributor
Contributor
6,413 Views
Registered: ‎05-26-2014

Hello ,

             Please find Workspace attached

Tags (1)
0 Kudos
Highlighted
Scholar
Scholar
8,833 Views
Registered: ‎09-05-2011

I tried to create a new SDK workspace using your hardware platform (Ethernet_hw_platform), but i encountered the following error:

intc_lwip.png

 

From the above error, it looks like you have not enabled the ethernetlite interrupts in your hardware project. Please note that this is a must when trying to use the lwip stack.

must.png

 

You may want to refer to the hardware project as mentioned in xapp1026

http://www.xilinx.com/support/documentation/application_notes/xapp1026.pdf 

 

Can you please check your hardware project if the interrupts are connected properly?

View solution in original post

0 Kudos
Highlighted
Contributor
Contributor
6,388 Views
Registered: ‎05-26-2014
Hi,
Thank u for ur time and help.That was the problem.I connected timer interrupt and just left ethernetlite interrupt unseen thinking that it will be connected by default.
Now i will try creating .mfs file.Hopefully, it should not give any problem.
0 Kudos