cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Contributor
Contributor
636 Views
Registered: ‎05-17-2018

Vitis hangs reading XSA

Jump to solution

Hi, I am unable to create a new application project on vitis 2020.1. Vitis seems to hang forever reading the hardware specification file (.XSA) when creating a new project:

1) select "create application project" from the vitis welcome page, which start a wizard.

2) after the wizard welcome page the user is asked to select an hardware specification file (.XSA). This is the first input from the user in this wizard procedure.

3) select any .xsa (in this case, as shown in the picture, I choose a .xsa included in the vitis installation for simple reproduction of this bug).

4) after clicking "next" I get a warning message on the top of the window ("Invalid application project name. Project name must be specified") and the wizard hangs on "Reading hardware specification". The wizard can only be terminated by killing the process.

screen_20200719_133646.png

 

Any help?

0 Kudos
Reply
1 Solution

Accepted Solutions
Newbie
Newbie
361 Views
Registered: ‎11-09-2020

I was facing the same issue for the longest time, but I managed to find a solution. Checking the IDE.log that got created in the vitis workspace folder, I found an error talking about xlsclients

19:52:01 ERROR : (XSDB Server)which: no xlsclients in ...

After installing the package which had that command (xorg-xlsclients), it worked without issue!

 

View solution in original post

7 Replies
Moderator
Moderator
587 Views
Registered: ‎09-12-2007

Can you share the XSA file please?

0 Kudos
Reply
Contributor
Contributor
582 Views
Registered: ‎05-17-2018

sure, I had to compress it to upload here.

0 Kudos
Reply
Moderator
Moderator
578 Views
Registered: ‎09-12-2007

I tried this real quick on my end without issue:

vitis.PNG

 

What OS are you using? Are you on a network drive?

0 Kudos
Reply
Contributor
Contributor
569 Views
Registered: ‎05-17-2018

Fedora 31, running on the physical drive. I will try in another system when I can.

0 Kudos
Reply
Contributor
Contributor
510 Views
Registered: ‎05-17-2018

Tried on another Fedora installation and with archlinux. It works with Fedora but have the same problem with the arch installation.

Even if they are not supported systems, I will try to investigate the issue when I have time.

0 Kudos
Reply
Newbie
Newbie
362 Views
Registered: ‎11-09-2020

I was facing the same issue for the longest time, but I managed to find a solution. Checking the IDE.log that got created in the vitis workspace folder, I found an error talking about xlsclients

19:52:01 ERROR : (XSDB Server)which: no xlsclients in ...

After installing the package which had that command (xorg-xlsclients), it worked without issue!

 

View solution in original post

Contributor
Contributor
335 Views
Registered: ‎05-17-2018

That was it, I missed that logfile. Thanks @connertenn!

0 Kudos
Reply