UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
7,888 Views
Registered: ‎05-26-2014

Vivado SDK Programming Failed

Jump to solution

Hi,

 

I'm tring to program Artix 7 board for Ethernet Iwip appliciation. But using Vivado SDK 2015.2 programming fails saying download.bit file is not found. The Console window gives following message

 

 

 

cmd /C updatemem -force -meminfo \
E:/*/project_5/project_5.sdk2/design_1_wrapper_hw_platform_0/design_1_wrapper.mmi -bit \
E:/*/project_5/project_5.sdk2/design_1_wrapper_hw_platform_0/design_1_wrapper.bit -data \
C:/Xilinx/Vivado/SDK/2015.2/data/embeddedsw/lib/microblaze/mb_bootloop_le.elf -proc \
/microblaze_0 -out \
E:/*/project_5/project_5.sdk2/design_1_wrapper_hw_platform_0/download.bit


****** updatemem v2015.2 (64-bit)
  **** SW Build 1266856 on Fri Jun 26 16:35:25 MDT 2015
    ** Copyright 1986-2015 Xilinx, Inc. All Rights Reserved.

source C:/Xilinx/Vivado/SDK/2015.2/scripts/updatemem/main.tcl -notrace
ERROR: [Updatemem 57-85] Invalid processor specification of: /microblaze_0. The known processors are: design_1_i/microblaze_0

 

 

 

How can I solve this issue ? Please suggest.

 

Thanks

0 Kudos
1 Solution

Accepted Solutions
Scholar stephenm
Scholar
15,216 Views
Registered: ‎05-06-2012

Re: Vivado SDK Programming Failed

Jump to solution

This is using updatemem. One of updatemems parameters is the -proc. If you open the MMI file and view the Instpath you will see what this should be set to (from your error message this is design_1_i/microblaze_0). However, in the command line being used, this is set to /microblaze_0.

 

So, the easiest way to fix this is to open the MMI and change the instpath to "microblaze_0" and re-running

0 Kudos
4 Replies
Scholar stephenm
Scholar
15,217 Views
Registered: ‎05-06-2012

Re: Vivado SDK Programming Failed

Jump to solution

This is using updatemem. One of updatemems parameters is the -proc. If you open the MMI file and view the Instpath you will see what this should be set to (from your error message this is design_1_i/microblaze_0). However, in the command line being used, this is set to /microblaze_0.

 

So, the easiest way to fix this is to open the MMI and change the instpath to "microblaze_0" and re-running

0 Kudos
Contributor
Contributor
7,868 Views
Registered: ‎05-26-2014

Re: Vivado SDK Programming Failed

Jump to solution

Hi ,

 

It did sove the problem. But instead of "microblaze_0", I edit it like "/microblaze_0".

 

So, next uestion which comes is everytime I need to make this changes? If so then it something where Tool needs a update. Because anytime .hdf file is changed or when you program FPGA board .mmi will be auto updated.

 

Thank you for help

 

Thanks

0 Kudos
Scholar stephenm
Scholar
7,862 Views
Registered: ‎05-06-2012

Re: Vivado SDK Programming Failed

Jump to solution

Yes, this looks like a bug in the HWH file that is exported to SDK that has the incorrect instpath.

This instpath is used in the Program FPGA GUI.

 

There are two ways to workaround it; modify the MMI, or modify the updatemem command line, and call the updatemem manually with the correct -proc option (in your case this should be design_1_i/microblaze_0)

Highlighted
Contributor
Contributor
7,841 Views
Registered: ‎05-26-2014

Re: Vivado SDK Programming Failed

Jump to solution

Ok. I tried both way and things are working.

 

Thank you for help

0 Kudos