UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer arkay99
Observer
367 Views
Registered: ‎06-19-2018

When debugging Zynq 7020 how to make Console 0 default?

I'm using SDK 2018.2. but have this small issue with 2016.4, 2017.4, and 2018.1 also. When I choose System Debugger on Local, after the code is downloaded, on my system (Win 7, Win 10), the console that is shown is always the console attached to Core #1, not Core #0. I have no code on Core #1, and only wish to work on Core #0 and have printf's outputting from that core. I know I can set a breakpoint, or set the debug to stop at main, which is what I do, then select the console for Core #0 and hit F8, however, I can't find a preference to have it default to Core #0. Also, is there a preference to have the SDK Terminal be the default output window without having to choose it every time I start the debugger after I stop it.

 

I know it's only a few keystrokes, but it becomes tiresome.

 

Is there a way to accomplish this?

0 Kudos
1 Reply
Moderator
Moderator
311 Views
Registered: ‎10-06-2016

Re: When debugging Zynq 7020 how to make Console 0 default?

Hi @arkay99,

 

I'm not sure if I understood properly your issue... I guess that you mean that the console is connected by default to a different serial port that then one used in Core#0, isn't it?

 

If so the easier way might be change your BSP setting to select a different uart for the stdin/stdout so it matches with the default SDK console configuration.

 

Regards
Ibai


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos