UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Scholar golson
Scholar
5,007 Views
Registered: ‎04-07-2008

XAPP1026 Question about udp.c file

Hi,

  I got the Echo Test to work once I increased the size of the Heap and Stack.  Now I am trying to see if I can substitue the echo.c file with the uecho.c file and

send udp packets to the ml505 board.  leaving everything same that is including the main.c and platform.c files in the project with the new file uecho.c.

 

What I find is that the UDP test is not working.  I can ping the address 192.162.1.10 and it works. The next step using telnet I tried to open a port at the

address 192.168.1.10 and it fails to open.  So I then looked for a UDP software package on the internet and found a package and ran it also and tried to open a UDP port

with it.  That software did not open a port either.

 

Thank You,

  Gary Olson

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
4,995 Views
Registered: ‎01-18-2008

Re: XAPP1026 Question about udp.c file

Think about what would happen when you connect a TCP program to a UDP port.

 

The appnote provides a tftpserver example which has clients on Windows. So you should look at that for UDP functionality.

And in most cases, you should try debugging further using ethereal/wireshark. Also look at the debugging hints in the appnote.

0 Kudos