UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor ivanrocker90
Visitor
5,111 Views
Registered: ‎02-26-2015

XPS Interrupt controller limited inputs range

Jump to solution

Hi, I'm working with an Interrupt Controller in a XPS system, I have 3 interrupt outputs for diferents peripherals and I would like  to conect them to the xps_intc, but xps_intc just have 2 intr-inputs wich are set in range [1:0], I supouse it could be changed, but I just don't know where. Does anybody know anything about this? thanks

0 Kudos
1 Solution

Accepted Solutions
Scholar stephenm
Scholar
8,889 Views
Registered: ‎05-06-2012

Re: XPS Interrupt controller limited inputs range

Jump to solution
Change the c_num_int parameter in the config. However, in XPS, if you open the MHS and add the interrupt to the intr port this will be updated automatically. For example:
....
Port intr = int1 & int2 & int3

You can add the interrupt by appending it with an &
0 Kudos
2 Replies
Scholar stephenm
Scholar
8,890 Views
Registered: ‎05-06-2012

Re: XPS Interrupt controller limited inputs range

Jump to solution
Change the c_num_int parameter in the config. However, in XPS, if you open the MHS and add the interrupt to the intr port this will be updated automatically. For example:
....
Port intr = int1 & int2 & int3

You can add the interrupt by appending it with an &
0 Kudos
Highlighted
Visitor ivanrocker90
Visitor
5,032 Views
Registered: ‎02-26-2015

Re: XPS Interrupt controller limited inputs range

Jump to solution

Thank you for your answer, I already did what you suggested me, I changed c_num_int to 3, and I added the interrupt to port intr using '&'  in the MHS, but  there are just 2 interruption sources conected to XPS_intc intr-inputs in the graphical desing view, and range wasn't updated, it http://forums.xilinx.com/t5/forums/replypage/board-id/EDK/message-id/34947kept being [1:0] in system assembly view > xps_intc_0. What do you think I'm doing wrong? 

0 Kudos