UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor cokezero
Visitor
8,393 Views
Registered: ‎09-09-2016

XSCT timeout when starting SDK

Jump to solution

Migrating our Artix 7 project from ISE to Vivado 2016 under Linux (Fedora 21).

We're trying to create/build a microblaze project from the command line (eventually via makefile).

 

But in fundamental testing of xsct, I get the error that xsct is unable to connect with the SDK for simple SDK commands such as  "toolchain"

 

I've installed Xvfb

via bash terminal:

$. /opt/Xilinx/SDK/2016.1/settings64.sh

$Xvfb :1&

$export DISPLAY=:1

$xsct

 

****** Xilinx Software Commandline Tool (XSCT) v2016.1
   **** Build date : Apr 8 2016-16:07:20
     ** Copyright 1986-2016 Xilinx, Inc. All Rights Reserved.

 

xsct% setws ./myworkspace

xsct% toolchain

Starting SDK.  This could take few seconds...

[60 seconds later]

Starting SDK. This could take few seconds... timeout while establishing a connection with SDK

xsct%

 

If, instead, I run xsdk independently it launches the SDK gui in x-windows, but we highly desire this to be command line only (TCL scripting).

The created ./myworkspace/SDK.log is blank.

 

Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
Visitor cokezero
Visitor
15,186 Views
Registered: ‎09-09-2016

Re: XSCT timeout when starting SDK

Jump to solution

I believe I have resolved my issue.

/etc/hosts did not have "localhost" on 127.0.0.1

instead it only had "mymachine.localdomain mymachine" aliasing 127.0.0.1

I added "localhost localhost.localdomain localhost4 localhost4.localdomain4" to 127.0.0.1

    127.0.0.1    localhost localhost.localdomain localhost4 localhost4.localdomain4 mymachine.localdomain mymachine

 

Discrete xsct commands and tcl scripting now works.

 

0 Kudos
12 Replies
Xilinx Employee
Xilinx Employee
8,370 Views
Registered: ‎08-01-2008

Re: XSCT timeout when starting SDK

Jump to solution

check these documents 

http://www.xilinx.com/support/answers/64200.html

http://www.xilinx.com/support/answers/64200.html
http://www.xilinx.com/support/documentation/sw_manuals/xilinx2015_1/SDK_Doc/SDK_concepts/sdk_c_batch_mode.html
http://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_2/ug1208-xsct-reference-guide.pdf
http://www.xilinx.com/video/hardware/how-to-develop-and-debug-using-xsct.html
http://www.xilinx.com/support/answers/65094.html

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Moderator
Moderator
8,300 Views
Registered: ‎03-19-2014

Re: XSCT timeout when starting SDK

Jump to solution

There is an issue with SSH scripting in 2016.1.  This will be fixed in 2016.3.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor cokezero
Visitor
15,187 Views
Registered: ‎09-09-2016

Re: XSCT timeout when starting SDK

Jump to solution

I believe I have resolved my issue.

/etc/hosts did not have "localhost" on 127.0.0.1

instead it only had "mymachine.localdomain mymachine" aliasing 127.0.0.1

I added "localhost localhost.localdomain localhost4 localhost4.localdomain4" to 127.0.0.1

    127.0.0.1    localhost localhost.localdomain localhost4 localhost4.localdomain4 mymachine.localdomain mymachine

 

Discrete xsct commands and tcl scripting now works.

 

0 Kudos
Contributor
Contributor
6,687 Views
Registered: ‎07-04-2016

Re: XSCT timeout when starting SDK

Jump to solution

@glena

Hi.

Can you clarify? I'm running this commands in and I get timeout error, is this the problem you meant?

 

 

tsotne@viineripirukas ~ $ source /cad/x_16/SDK/2016.1/settings64.sh
tsotne@viineripirukas ~ $ xsdk -batch

****** Xilinx Software Commandline Tool (XSCT) v2016.1
**** Build date : Apr 8 2016-16:07:20
** Copyright 1986-2016 Xilinx, Inc. All Rights Reserved.

xsct%
xsct%
xsct% setws workspace
..# set variables
xsct% createhw -name hw_0 -hwspec $dir/design_1_wrapper.hdf
xsct%
xsct% Starting SDK. This could take few seconds...
timeout while establishing a connection with SDK
xsct%
xsct%

 

 

and can i fix that by changing this number  "variable sdk_launch_timeout 60000" in file /cad/x_16/SDK/2016.1/scripts/xsdb/xsdb/xsdb.tcl ? (on line 1629)

 

....
    }
}

namespace eval ::xsdb {
    variable version 0.1
    variable curchan {}
    variable curtarget ""
    variable xsdb_src_dir
    variable command_metadata {}
    variable bptable [dict create]
    variable bpfmttable [dict create]
    variable streamtable [dict create]
    variable streamreader_bufs [dict create]
    variable memmaptable [dict create]
    variable memmap_ctxs [dict create]
    variable designtable [dict create]
    variable swdesignmaps [dict create]
    variable info_messages 0
    variable force_mem_accesses 0
    variable sdk_launch_timeout 60000
    variable profile_config [dict create]
    variable expr_fmt_dict [dict create]

    dict set expr_fmt_dict 1 [dict create 1 cu 2 su 4 iu 8 wu]
    dict set expr_fmt_dict 4 [dict create 1 cu 2 su 4 iu 8 wu]
    dict set expr_fmt_dict 2 [dict create 1 c 2 s 4 i 8 w]
    dict set expr_fmt_dict 7 [dict create 1 c 2 s 4 i 8 w]
    dict set expr_fmt_dict 3 [dict create 4 r 8 q]

    proc checkbool {b} {
    if { ![string is boolean -strict $b] } {
        error "expected boolean but got \"$b\" instead"
....

Thank you

0 Kudos
Contributor
Contributor
6,686 Views
Registered: ‎07-04-2016

Re: XSCT timeout when starting SDK

Jump to solution
@note: this might sound weird but i have to request the change of that file on server - where i have no edit rights.. otherwise i would have tried it myself...

p.s. it prints this error exactly after 60sec. or maybe there is other bug and that is the reason it might take 'forever' to launch?
0 Kudos
Visitor cokezero
Visitor
6,663 Views
Registered: ‎09-09-2016

Re: XSCT timeout when starting SDK

Jump to solution
I had tried adding timeout to over an hour with no success. No amount of additional timeout waiting would have resolved the fundamental networking issue my machine had. If you are still waiting 60+ seconds to start the SDK, but it eventually starts, perhaps you need to write a new question to the forum and/or involve your server admin.
0 Kudos
Xilinx Employee
Xilinx Employee
6,658 Views
Registered: ‎10-21-2010

Re: XSCT timeout when starting SDK

Jump to solution

Hi,

 

The launch timeout can be increased thru configparams command. However, increasing the timeout doesn't help always and is only needed when SDK is slow to start (for example, if you're launching it from a network drive).

 

Are you able to start SDK manually from the same terminal and using the same workspace? If so, can you set the log level to trace (Window -> Preferences -> Xilinx SDK -> Log Information Level) from the SDK GUI and then reuse the same workspace from XSCT, and send the log. You may also want to delete ~/.Xilinx, before starting XSCT/SDK

0 Kudos
Contributor
Contributor
6,645 Views
Registered: ‎07-04-2016

Re: XSCT timeout when starting SDK

Jump to solution

Hi @sadanan

 

yes i can launch sdk manually and i did change it to trace.

but however when xsct does not write anything into that log file, even though i specified same directory as workspace.

also, i was not able to somehow specify the log file for xsct, no option for that.

p.s. in general sdk launch takes 5-10 seconds.

What else can be done?

0 Kudos
Visitor cokezero
Visitor
6,634 Views
Registered: ‎09-09-2016

Re: XSCT timeout when starting SDK

Jump to solution
If your /etc/hosts file has "localhost" on the line reading 127.0.0.1 and you are still having problems, then you have a different issue. This issue is marked solved and cannot have 2 solutions marked. I suggest you create a new topic to get more help from others than use this old topic.
0 Kudos
Contributor
Contributor
3,156 Views
Registered: ‎07-04-2016

Re: XSCT timeout when starting SDK

Jump to solution

yes, but anyways, i fixed the problem, i had to set:

setenv SWT_GTK3 0

 

probably its specific only for me because of reasons, so not important to open another topic

Newbie eaaltonen
Newbie
2,423 Views
Registered: ‎08-23-2017

Re: XSCT timeout when starting SDK

Jump to solution

@tsotnep2 wrote:

yes, but anyways, i fixed the problem, i had to set:

setenv SWT_GTK3 0

 

probably its specific only for me because of reasons, so not important to open another topic


No, this seems to be required on Ubuntu 16.04 (at least on the default Unity desktop).

0 Kudos
Visitor thomas144
Visitor
2,179 Views
Registered: ‎06-20-2017

Re: XSCT timeout when starting SDK

Jump to solution

I found that typing this:

 

export SWT_GTK3=0

 

 

just before "petalinux-build" fixed it for me.