cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jflynn129
Visitor
Visitor
614 Views
Registered: ‎05-07-2019

XSDK can't find download.bit

I have been trying for a few days to install and use the XSDK.  I'm running Ubuntu 18.04LTS and installing using sudo.  When I run eclipse, it says:

jim@jim-ThinkPad-T420:/tools/Xilinx/SDK/2018.3/eclipse/lnx64.o$ ./eclipse
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.eclipse.osgi.storage.FrameworkExtensionInstaller (file:/tools/Xilinx/SDK/2018.3/eclipse/lnx64.o/plugins/org.eclipse.osgi_3.11.1.v20160708-1632.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of org.eclipse.osgi.storage.FrameworkExtensionInstaller
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

 

Any idea what the issue is and how to resolve?  Was 2018.3 tested prior to release, seems like this issue would have been found when installing on a clean ubuntu platform.

0 Kudos
Reply
1 Reply
jflynn129
Visitor
Visitor
589 Views
Registered: ‎05-07-2019

A newbie issue? You can’t run eclipse directly, you must run ‘xsdk’ which will then run eclipse indirectly after whatever setup. Startup of eclipse wasn’t to my knowledge described anywhere and I found this info by googling around.