cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
7,755 Views
Registered: ‎01-10-2014

Xilinx SDK 2013.4 crashes after launch

Jump to solution

Hello everyone!

Here's the problem: 

I'm using Vivado 2013.4. After generating bitstream I select "Export Hardware for SDK" and pick "Launch SDK". SDK launches but crashes seconds after launch with this error (see attached file).

Java version is 7 update 67 (newest).

Windows version is 7 x64.

Has anyone met this? I guess I have to add some flags to eclipse.ini or something.

 

Screenshot 2014-09-18 12.23.50.png
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
11,163 Views
Registered: ‎01-10-2014

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution

Well, I tried to launch the same project on another computer with the same Windows and Vivado versions and SDK also crashed.

So I just deleted the <project>.sdk folder and did it again and now it's o'k.

View solution in original post

0 Kudos
9 Replies
Highlighted
Adventurer
Adventurer
7,752 Views
Registered: ‎01-10-2014

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution
UPD: rebooting or reinstalling Java and Vivado didn't help.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
7,741 Views
Registered: ‎04-16-2012

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution

Hi,

 

Are you able to invoke SDK standalone?

Which version of java are you using?

 

Try updating the java to latest version.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Adventurer
Adventurer
7,739 Views
Registered: ‎01-10-2014

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution
Yes, I'm able to launch SDK from Start menu and choose any workspace and it works. This error occurs only after exporting hardware for SDK with choosing Launch SDK.
My Java version is 7 update 67 (latest). And the error started occuring only after this update.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
7,727 Views
Registered: ‎04-16-2012

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution
Hi,

Is hardware being exported? You can check this by confirming whether "project_name.sdk" folder is created.

Also invoke vivado by using the following command: vivado -jvm Xmx4096m

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Adventurer
Adventurer
7,726 Views
Registered: ‎01-10-2014

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution
Yes, hardware export works o'k.
So where shall I type that command?
0 Kudos
Highlighted
Adventurer
Adventurer
7,723 Views
Registered: ‎01-10-2014

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution
UPD: well, now it started to crash every time I build project. Not funny at all.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
7,722 Views
Registered: ‎04-16-2012

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution
Hi,

Follow below steps:

1. Open Command Prompt
2. Navigate to Vivado installed directory
3. Run the command: settings64.bat
4. Then run the command: vivado -jvm Xmx4096m

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Adventurer
Adventurer
7,705 Views
Registered: ‎01-10-2014

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution

That doesn't help. SDK still crashes.

0 Kudos
Highlighted
Adventurer
Adventurer
11,164 Views
Registered: ‎01-10-2014

Re: Xilinx SDK 2013.4 crashes after launch

Jump to solution

Well, I tried to launch the same project on another computer with the same Windows and Vivado versions and SDK also crashed.

So I just deleted the <project>.sdk folder and did it again and now it's o'k.

View solution in original post

0 Kudos