UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor mlujan476
Visitor
329 Views
Registered: ‎03-29-2018

ZC706 not showing up in SDK

Hello everyone,

 

My company bought a Zynq 7000 (ZC706).  We are trying to use it with a Dell XPS 8910 running Ubuntu 16.04.  I can ping the device from the linux terminal, so I know that both machines can communicate.  The problem occurs while I am in the Xilinx SDK.  

 

The port connected to the Zynq board doesn't seem to be recognized.

 

So I followed a process from pg. 14 of "Example Project: Creating a New Embedded Project with Zynq SoC" at the link: https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_2/ug1165-zynq-embedded-design-tutorial.pdf

 

I know the process is for the ZC702, but I couldn't find one for the ZC706.

 

I go through creating the create the project in vivado, follow the process until I eventually export the hardware and launch the SDK.  However instructions 6-8 on pages 27 and 28 do not work for me.  When I open the terminal and set the terminal settings I get a message saying "no such port".  I've tried setting the port to COM1 - COM3, since I'm using Ubuntu I went and searched which port is being used by the Zynq board and it's ttyUSB1, when I use this as the port setting, I still get the message "no such port".  

 

On the zynq board, I've experimented with all possible combinations of wiring using the uart, jtag and rj45.  (ie. no uart, yes jtag, yes rj45; all combinations).  Also I've tried setting the SW11 switches to 00000 and 00110.

 

I used the process from this link to troubleshoot: https://www.xilinx.com/support/answers/58053.html

 

It says to press the SW2 button after powering on the board, to reset it.  However this doesn't work for me either.  

 

Any help would be greatly appreciated.  If you need any clarification from me, please ask.  Btw if you don't have anything nice/helpful to say, take your mother's advice and don't say anything at all.

 

Thanks!

0 Kudos
1 Reply
Moderator
Moderator
282 Views
Registered: ‎09-12-2007

Re: ZC706 not showing up in SDK

Ok, so these issues are mostly always related to cable driver issues:

https://www.xilinx.com/support/answers/59128.html

 

Can you then connect the board you your machine, and power cycle:

In the XSCT in SDK (Xilinx -> XSCT Console), can you try do the following:

  • connect
  • targets

Do you see anything here?

 

If not, then there is most likely an issue with the cable drivers.

 

0 Kudos