cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
3,052 Views
Registered: ‎07-05-2017

petalinux-v2017.3-final-installer.run missing xvfb-run

Jump to solution

I have been trying to upgrade my petalinux by installing the "petalinux-v2017.3-final-installer.run" on my Ubuntu 16.04 machine. I also downloaded the 2017.3 Zedboard BSP. 
When I go through the "petalinux-v2017.3-final-installer.run" installation, I had bunch of missing packages which I was able to get by "apt-get update" and "apt-get install -y <missing_package_names>. I was able to get most of them except "xvfb-run" and "textinfo". Has anyone ran into the same issue as you upgraded your Petalinux to 2017.3 and how did you resolve it?
Thanks,
Aynilian.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Explorer
Explorer
4,324 Views
Registered: ‎07-05-2017

Hi all,

 

I think I solved it:

 

sudo apt-get install xvfb  did the trick.

 

successfully installed petalinux-v2017.3-final-installer.run.

 

Thanks,

Aynilian

View solution in original post

0 Kudos
8 Replies
Highlighted
Scholar
Scholar
3,047 Views
Registered: ‎02-27-2008

Post once.

 

We will see it.

 

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Explorer
Explorer
3,027 Views
Registered: ‎07-05-2017

Austin,

 

Why can't I see my post in the "Embedeed Linux" Forum? If I post it once, is there a way to show my post in multiple forums?

 

Thanks,

Aynilian

0 Kudos
Highlighted
Scholar
Scholar
3,021 Views
Registered: ‎02-27-2008

Because one post suffices.

 

If not answered, it gets flagged by a moderator to pursue.

 

If you multiple post, you clutter up the boards, and we will clean it up.

 

Again, one post is completely sufficient.

 

Even in the wrong board (it will just get moved to the 'right' board).

 

In this vibrant closely watched community (forums.xilinx.com), you will get an answer.  And you will get it faster.

 

My answer to your question is "did you setup the github referenced properly?"

 

This allows the Petalinux build process to go find everything needed.

 

At least, that was (one) problem I had.

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Explorer
Explorer
3,009 Views
Registered: ‎07-05-2017

Hi Austin,

 

I'm not sure how to do this "github referenced properly?"

 

Does this constitute modifying "/etc/apt/source.list" and changing the attributes to "universe or multiverse" in-front of

"deb http://archive.ubuntu.com/ubuntu" ?

 

Thanks,

Aynilian

 

 

 

 

0 Kudos
Highlighted
Scholar
Scholar
3,006 Views
Registered: ‎02-27-2008

No,

 

That is not it.  Now I cannot find it.  But I do recall that building petalinux I needed to have a means of allowing sources to get pulled from the github.  Fuzzy now, I cannot remember the details ,,,

 

 

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Explorer
Explorer
3,005 Views
Registered: ‎07-05-2017

I edited /etc/apt/sources.list.

 

I did this:

cd /etc/apt/

 

$/etc/apt/ sudo chmod 666 sources.list  "This was necessary, because the file was in read only mode"

 

/etc/apt/gedit sources.list

 

changed this section by adding universe multiverse:

 deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse

 deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted universe multiverse

 

then I did this

apt-get install -y xvfb-run  (E: Unable to locate package xvfb-run)

apt-get install -y texinfo (Got it!_

 

Then went back and re-ran the installations:

./petalinux-v2017.3-final-installer.run

 

Partial success!

Now I'm down to 1 missing package (xvfb-run).

 

Thx

Aynilian

 

0 Kudos
Highlighted
Explorer
Explorer
2,994 Views
Registered: ‎07-05-2017

 

apt-get did not find it by searching, I found and downloaded xvfb-run.1.gz from an ubuntu website. 

 

How do I install xvfb-run.1.gz that is in my Downloads directory?

 

Thanks,

Aynilian

0 Kudos
Highlighted
Explorer
Explorer
4,325 Views
Registered: ‎07-05-2017

Hi all,

 

I think I solved it:

 

sudo apt-get install xvfb  did the trick.

 

successfully installed petalinux-v2017.3-final-installer.run.

 

Thanks,

Aynilian

View solution in original post

0 Kudos