UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer tom667
Observer
301 Views
Registered: ‎09-05-2018

"dow" command is very slow

My FPGA-SDK builds on my Zynq with a Platform Cable USB II are rather slow on a Zynq 7014S on custom hardware.

The problem exhibits itself as the FPGA bitstream image (~3MB) completing within a few seconds, but the elf image taking almost 35 seconds despite being similar in size.

This is slowing down my debugging cycle.  To investigate this issue I sent the 'dow' command from xsct and found the transfer rate was not exceeding 0.1MB/s. I have tried a number of JTAG frequencies; it does not seem to make an enormous difference.

I have tried both USB2 and USB3 ports on my machine.  I'm using Windows 10 with SDK 2018.3.

Is there a known fix for this issue?

Thanks

4 Replies
Moderator
Moderator
219 Views
Registered: ‎10-06-2016

Re: "dow" command is very slow

Hi @tom667 

On which memory are you downloading the ELF file? Usually JTAG is the bottleneck of the chain but different memories might be running even at slower clock rates...

Regards


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Observer tom667
Observer
217 Views
Registered: ‎09-05-2018

Re: "dow" command is very slow

Hi Ibai,

I believe that the program will be downloaded into either OCM or DDR3,  as the board has no on-board flash right now.  When I'm back in the office I'll check the linker script to confirm.

Thanks,

Tom

0 Kudos
Observer tom667
Observer
111 Views
Registered: ‎09-05-2018

Re: "dow" command is very slow

Sorry for the delay as I forgot about this post.  The memory the application is being downloaded into is DDR3.  So I don't imagine that is the bottleneck.

0 Kudos
Xilinx Employee
Xilinx Employee
79 Views
Registered: ‎02-01-2008

Re: "dow" command is very slow

Try changing your target from MPCore #0/1 to APU before downloading to DDR

0 Kudos