cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
5,908 Views
Registered: ‎02-03-2011

xpsgui: cannot connect to X server :0.0

Jump to solution

Hi,

 

I am trying to use a processor for a project. So, i followed the method described in the EDK Concepts, Tools,
and Techniques guide and When i try to launch XPS in ISE, i get the error

 

xpsgui: cannot connect to X server :0.0

 

What could be wrong?

0 Kudos
Reply
1 Solution

Accepted Solutions
7,562 Views
Registered: ‎02-03-2011

When i tried to launch xps standalone, i saw there were errors in the environment variables for some reason. So unset them and re sourced settings64.csh and now it works. Key was to have proper environment variables it seems. Thx.

View solution in original post

0 Kudos
Reply
5 Replies
Xilinx Employee
Xilinx Employee
5,898 Views
Registered: ‎08-01-2007

praveen,

 

Which OS are the Xilinx tools installed on?

0 Kudos
Reply
5,881 Views
Registered: ‎02-03-2011

I have it on Linux. Mandriva latest version.

0 Kudos
Reply
5,877 Views
Registered: ‎02-03-2011

Launching XPS GUI...
No protocol specified
xpsgui: cannot connect to X server :0.0

 

The above is the sequence. What protocol is it expecting. Should i set some variable or path for this work?

0 Kudos
Reply
Explorer
Explorer
5,848 Views
Registered: ‎08-02-2007

can you launch XPS standalone (not launching from the ISE projnav GUI)?  It would be good to see if you can get the EDK tools running without launching from within ISE.  You can launch using the command 'xPS' as long as all of the environment variables have been set up correctly.

0 Kudos
Reply
7,563 Views
Registered: ‎02-03-2011

When i tried to launch xps standalone, i saw there were errors in the environment variables for some reason. So unset them and re sourced settings64.csh and now it works. Key was to have proper environment variables it seems. Thx.

View solution in original post

0 Kudos
Reply