UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
7,212 Views
Registered: ‎03-23-2015

xsdk error when running in batch mode (Invalid MIT-MAGIC-COOKIE-1)

Hello, 

 

my team and I have rely heavily on TCL script-based continuous integration and among others, we have a nightly build system in charge of synthesizing different projects everyday to keep track of the repositories state. Since some of those projects are Zynq based we also generate FSBL, and other applications in order to create flash boot images.

 

We have run into a pretty strange SDK error. I am fairly certain it has something to do with the X-Server status, even though the tool is called in batch mode.

We have not find a way to isolate the error, as it seems to happen eventually whatever the environment's status is. However, some flows are more likely to cause it. For example, we use a Load Sharing Facility to run the builds, when running the process in this farm the error is much more likely to appear. Also, we use a variety of ways to connect to our workstations, one is through NX (No Machine) a remote desktop client, while another is ussing Putty/MobaXterm or any other ssh client. Even if the build process is ran locally (in the remote workstation, but not in the LSF farm) the error is much more likely to appear when using Putty/MobaXterm than when we use a remote desktop client like NX.

 

I have looked arount for the eclipse error trace but I have been unable to find anything, which makes me believe it might be something more xilinx related. I am attaching the log as a separate file since the error is too long.

 

I would really appreciate any help :P

 

Thanks!

0 Kudos
1 Reply
Explorer
Explorer
7,195 Views
Registered: ‎03-23-2015

Re: xsdk error when running in batch mode (Invalid MIT-MAGIC-COOKIE-1)

Hello,

 

I have been looking around and I am allmost sure it is something about running xsdk headless or not headless (no monitor /X-Server).

 

while Searching I stumbled across this: http://www.xilinx.com/support/documentation/sw_manuals/xilinx2014_4/SDK_Doc/concepts/sdk_c_headless_mode.htm

 

It uses a different way of invoking xsdk, as we just call xsdk -batch -source file.tcl, and that seems to cause problems. Howerver, this document is for version 2014.4, and the hwspec file they talk about has changed from an xml to an hdf. I have tried performing the process and giving it the HDF instead of the XML and I keep getting some error saying "name is not defined". I have rechecked my XML and I am pretty sure it's correct.. Maybe it has something to do with the versition? (I am using 2015.4).... I have not been able to find the equivalent document for 2015.4...

0 Kudos