UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

2014.2 Image Build Processes Error

Newbie
Posts: 1
Registered: ‎02-10-2015

Re: 2014.2 Image Build Processes Error

this works for me on Ubuntu 14.04. Thanks!

Visitor
Posts: 18
Registered: ‎10-12-2014

Re: 2014.2 Image Build Processes Error

I am seeing this same issue but none of the fixes thus far in this thread have resolved my issue.  I'm using  Ubuntu 14.04.1 LTS 64-bit and I have petalinux-v2014.4-final installed in /opt.

 

Hey dmitrysh:

 

When you say "this works for me on Ubuntu 14.04"- which fix (there are many here) were you referring to?  If you were referring to the Makefile patch suggested by I find that this had already been corrected in petalinux-v2014.4-final and yet I still have the issue.

 

Adventurer
Posts: 68
Registered: ‎11-10-2012

Re: 2014.2 Image Build Processes Error

Hi,

Concerning the
[ERROR] make[2]: *** [.pkg_stagefs] Error 255

I had the same error on Ubuntu 14.04.1 LTS 64-bit and petalinux-v2014.4.

I had also noted the missing dependency of petalinux-v2014.4-final/tools/packagemanager/bin/dpkg :

"libselinux.so.1 => not found"

So, i installed the the missing file with :
sudo apt-get install libselinux1:i386

Now the petalinux-build is working.

Hope it helps

Regards
Participant
Posts: 50
Registered: ‎04-13-2015

Re: 2014.2 Image Build Processes Error

Getting that i386 libselinux did the trick.

 

sudo apt-get install libselinux1:i386

 

That should be added to the UG1144 PetaLinux Tools Documentation - Reference Guide

 

-Gary