UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant bpb
Participant
5,983 Views
Registered: ‎09-11-2016

Checking sstate mirror taking forever

"Checking sstate mirror object availability" takes a very long time during "petalinux-build".  Is there any way to mitigate this?

 

0 Kudos
10 Replies
Moderator
Moderator
5,938 Views
Registered: ‎12-04-2016

Re: Checking sstate mirror taking forever

Hi

 

Since sstate mirror check is part of petalinux-build, you can only speed up this process if you increase parallel threads in petalinux-config ---> Yocto settings ---> Select No of threads here as max 8

 

Also, it depends on host machine on which you are building, if its fast enough, then build will also be fast

 

 

Best Regards

Shabbir

 

0 Kudos
Participant bpb
Participant
5,913 Views
Registered: ‎09-11-2016

Re: Checking sstate mirror taking forever

There is decent CPU utilization by default so I would guess parallel build is enabled.  I tried changing this manually, as suggested, and there doesn't seem to be a difference.

 

I am seeing ~20 minutes to "petalinux-build" right after a previous "petalinux-build".  4 cores @ 4.4GHz (HTT disabled) Ubuntu 16.04 under VMware Workstation.  No change in anything, just a rebuild.  It seems to spend most of the time "Checking sstate mirror".

 

I've gone through compiling the kernel on this VM before, and a nop rebuild doesn't take much time.  I suspect the slowdown is related to the Yocto/Bitbake tooling?

 

0 Kudos
Highlighted
Visitor phani.kara
Visitor
5,762 Views
Registered: ‎11-10-2016

Re: Checking sstate mirror taking forever

I can confirm that I have the same problem as well. Disconnecting network on the VirtualBox VM used to make it proceed further but even this step does not help now. waiting for 1 hour now with no hope in sight. Rebooting host (and VM) has no effect.

0 Kudos
Participant bpb
Participant
5,675 Views
Registered: ‎09-11-2016

Re: Checking sstate mirror taking forever

This appears to be fixed in Petalinux 2017.2 - at least for a simple "Create Block Design" -> "Add Zynq" -> "Generate Bitstream" -> "petalinux-create ..." -> "petalinux-build"

0 Kudos
Explorer
Explorer
5,459 Views
Registered: ‎02-05-2008

Re: Checking sstate mirror taking forever

The issue exists with petalinux 2017.2. It takes 45 to 55 mints every time. How to reduce the time?

0 Kudos
Observer mascot02
Observer
5,384 Views
Registered: ‎04-11-2013

Re: Checking sstate mirror taking forever

me too,  it take  about 1 hour  just to check sstate mirror  object , and the check occurred  two times;

0 Kudos
Observer vacajk
Observer
5,305 Views
Registered: ‎01-21-2017

Re: Checking sstate mirror taking forever

I am using the PetaLinux 2017.2 in the virtual machine of CentOS 7.3.

I found a way to reduce the time of "Checking sstate mirror object availability".

 

Firstly, you should download the sstate-cache from the webset:

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/embedded-design-tools.html

And set the local sstate-cache directions for arm and downloads.

 

Secondly, before you using the "petalinux-build". You should disconnect the ethernet link of the virtual machine.

 

Then you can speed up the process of the Checking sstate mirror....

 

123.png

0 Kudos
Observer mascot02
Observer
5,267 Views
Registered: ‎04-11-2013

Re: Checking sstate mirror taking forever

thanks ,it make useful for me ;

0 Kudos
Visitor eatnafou
Visitor
4,856 Views
Registered: ‎10-25-2017

Re: Checking sstate mirror taking forever

This is helpful and it does speed things up. It was showing hours during that stage of the build until I disconnected from the network. I really don't want to have to disconnect the network everytime I want to do a build. Is there any other way beside disconnecting the network? There has to be.

0 Kudos
Visitor mrzhang_
Visitor
2,301 Views
Registered: ‎11-26-2017

Re: Checking sstate mirror taking forever

petalinux-config->

       YOCTO  setting ->

                           Enbale  sstate cache  internet feeds. (Don't  select this option )

 

Then, I  need not disconnect my internet, it can feed up compile speed.