cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Anonymous
Not applicable
3,898 Views

Cross-tool 0.42: Tool-chain compilation process fail

Hello,

during the Tool-chain compilation process I get this error:
----------------------------------------------------
*** These critical programs are missing or too old: [B]as ld gcc[/B]
*** Check the INSTALL file for required versions.
----------------------------------------------------
After checking my system which is [B]Ubuntu 10.10 Maverick Meerkat[/B]:
the package containing those tools is binutils version = [B]2.20[/B]

and for some specific reason I configured the Cross-tool to download and use binutils-[B]2.15[/B]

I have a little experience with Linux, would you please suggest me a solution to fix the problem.

Thanks

0 Kudos
3 Replies
linnj
Xilinx Employee
Xilinx Employee
3,890 Views
Registered: ‎09-10-2008

Why are you trying to build the tools?

 

I realize our tools are not in great shape, but have you used the binaries we provide?

 

If you don't know Linux much, building the GNU tools is a hard task IMHO.

0 Kudos
Anonymous
Not applicable
3,883 Views

 

I want to run Linux on the PPC405 of the Virtex2P in XUPV2P Board.

 

I'm doing that to create the cross-compiler environment that I will use to compile the PPC405 Kernel.

 

I didn't know that there's anything available to download from XIlinx related to porting linux on PPC405

 

If you have better idea please let me know

 

0 Kudos
linnj
Xilinx Employee
Xilinx Employee
3,867 Views
Registered: ‎09-10-2008

You can download the ELDK from denx and it has the PowerPC GNU tools binaries ready to use. I wouldn't suggest building GNU tools with out more experience.  Take anything you can prebuilt so that you don't have too many variables in the system.

0 Kudos