cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
644 Views
Registered: ‎07-31-2018

Disable stdout output in UART.

When PetaLinux is loaded, messages are sent to the screen and duplicated in the UART(dev/ttyPS0), which I need to use for data exchange. How to disable stdout output in UART?

0 Kudos
1 Reply
Highlighted
572 Views
Registered: ‎04-12-2018

Re: Disable stdout output in UART.

An easy way is to change your bootargs in uboot...

You need to first workout your standard boot args, this can be determined from the device tree OR on the board just 'cat /proc/cmdline'

 

Like mine:

hostname:~# cat /proc/cmdline
earlycon clk_ignore_unused

 

Then in u-boot simply (for instance sending all console output to tty0, you will see some inital boot messags but then it will go quiet.

 

setenv bootargs 'earlycon clk_ignore_unused console=tty0'

boot

 

Regards,

Mark

0 Kudos