We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Visitor toshibo
Registered: ‎09-11-2013

Fatal error: xenv_standalone.h: No such file or directory

Dear all,

I would like to create an Application Project based on the FS-BOOT (by PetaLogic) template.

As soon as I finish to create the Application, I obtain:

Fatal error: xenv_standalone.h: No such file or directory


I already saw http://forums.xilinx.com/t5/Embedded-Linux/Petalinux-v12-12-auto-config-h-missing/m-p/302751#M5756 but it seems to not work for me.

I am using Vivado 2013.2, ubuntu 11.04, petalinux 2013.04. My board is a zedboard.


Here what I do:

1) From bash -> source setting.sh (with the patch mentioned here http://www.xilinx.com/support/answers/56388.htm ) to set the $PETALINUX path

2) I export my Vivado project in SDK

3) I add repository from $PETALINUX/hardware/edk_user_repository

4) I create an Application Project:

     -> Hardware Platform: zedboard

     -> OS platform            : Petalinux

5) I set the templates -> FS-BOOT


As soon as I click Finish, it starts  "Build of configuration Debug for project......." and then

Fatal error: xenv_standalone.h: No such file or directory


Now, it does all by itself, so where is my mistake?

There is something wrong in the procedure?


Thanks a lot for your help.






I also tried o create a Zynq FSBL project with XSDK stanalone BSP with "Zynq FSBL" template as explained in UG980 -> Board Bringup Guide but I obtain "fatal error: xil_io.h: No such file or directory". I did it just to follow exactly that guide but with no results...



0 Kudos
1 Reply
Visitor toshibo
Registered: ‎09-11-2013

Re: Fatal error: xenv_standalone.h: No such file or directory

Dear all,


one step at time...

it seems it was a problem in my Ubuntu settings:

it tried to do gmake but I have "only" make.


If it happens again, try to do:

sudo ln -s /usr/bin/make /usr/bin/gmake
It should work.


Now, as you know, when you fix a problem, a even bigger problem happens.

Now I have two new errors:

../src/fs-boot.h:72:21: error: unknown type name 'u32'
../src/fs-boot.c:57:2: error: #error "Unknown architecture"


but I'll try to fix also them.


Any suggestion (or inspiration) is welcome.




0 Kudos