cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Participant
Participant
923 Views
Registered: ‎11-27-2018

How to add exfat support to petalinux?

Hi all,

I'm using sdcard to store files with my petalinux board, the old 4G bytes card formmated with FAT32 works fine, but it's class 4, the writing speed is rather slow (about 2M/s).  Today I bought a samsung sdcard, which is 64G bytes , class 10, u3, it should be much faster. But Windows seems only support exfat and ntfs for these large capacity memory cards, so I format it with exfat.

Then I found petalinux does not support exfat by default. By digging this forum, I found the solution:

https://forums.xilinx.com/t5/Embedded-Linux/How-to-include-a-bigger-GNU-package-to-Petalinux/m-p/841939

and do as follows:

Edit the file:

project-spec/meta-user/recipes-core/images/petalinux-image.bbappend

add the following:

IMAGE_INSTALL_append = " fuse-exfat"

and then run petalinux-config -c rootfs to enable fuse-exfat, and then rebuild.

After flash the new kernel, the sdcard seems still not supported, when I mount it, it prints:

root@zynq-rec:~# mount /dev/mmcblk0p1 /mnt/
FUSE exfat 1.2.3
fuse: device not found, try 'modprobe fuse' first
root@zynq-rec:~#

What should I do next? Thanks.

 

0 Kudos
2 Replies
Highlighted
Voyager
Voyager
886 Views
Registered: ‎09-14-2016

Hi,

Maybe try to add exfat-utils also,

 

Cheers,

Trigger

0 Kudos
Highlighted
Participant
Participant
808 Views
Registered: ‎11-27-2018

I added exfat-utils but still not work.

0 Kudos