UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Scholar vanmierlo
Scholar
7,915 Views
Registered: ‎06-10-2008

How to disable ethernet at petalinux boot

Hi,

 

I found AR#59073 which seems to describe what I wish to accomplish (but for petalinux 2013.10): do not start the ethernet controller at boot-up. However in petalinux 2015.2.1 it seems impossible to disable init-ifupdown.

 

I don't want to use DHCP to get an IP-address and I also don't want all my boards to start up with the same fixed IP-address. I want to set the IP-address at the end of boot-up with a script of my own. The latter is easy, but how to do the first?

 

Kind regards,

Maarten

0 Kudos
4 Replies
Scholar vanmierlo
Scholar
7,909 Views
Registered: ‎06-10-2008

Re: How to disable ethernet at petalinux boot

Argh, and if I manually set CONFIG_ROOTFS_PACKAGES_INIT_IFUPDOWN=n then I also don't get the loopback interface.

 

Is it really so extraordinary to have several Zynq's running linux in a larger setup?

And does Xilinx really expect all users to either use DHCP or rebuild the rootfs for every machine?

 

0 Kudos
Participant julian.bauer
Participant
2,766 Views
Registered: ‎11-18-2016

Re: How to disable ethernet at petalinux boot

have you fould a solution for diable ethernet at boot time?
0 Kudos
Scholar vanmierlo
Scholar
2,757 Views
Registered: ‎06-10-2008

Re: How to disable ethernet at petalinux boot

Not really. I usually set an invalid IP address now, but it's not quite the same as having the interface down at startup.

See also http://stackoverflow.com/questions/10456044/what-is-a-good-invalid-ip-address-to-use-for-unit-tests

Moderator
Moderator
2,746 Views
Registered: ‎04-17-2011

Re: How to disable ethernet at petalinux boot

petalinux-config:
Subsystem AUTO HW Settings:
Ethernet Settings -->
Set it to manual

This may help you.
Regards,
Debraj
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------