UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Advisor ronnywebers
Advisor
3,142 Views
Registered: ‎10-10-2014

Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution

I'm creating a VM to run Petalinux 2017.2

 

referring to UG1144, table 1-3 : a number of tools/libraries are mentioned, these need to be installed for Petalinux 

 

not being a linux admin / expert, I have the following questions :

 

Q1 : how important is it to have the exact mentioned version in the table of these packages? I'm using aptitude to installl these packages, can I just install the 'latest version' of each package? Or does it need to be exactly that version? 

 

i.e. can I just use 'aptitude install 'tofrodos' ? or do I somehow need to specifiy the 'tofrodos_1.7.13 ...' ?

 

Q2 : should I also run 'sudo aptitude update' to update all installed libraries?

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
4,790 Views
Registered: ‎04-24-2017

Re: Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution

Hi @ronnywebers,

 

A1: 

On Ubuntu-16.04 LTS you no need to worry about upgrading the packagelist from apt pacakage manager. PetaLinux 2016.4 onwards is backend Yocto. AFAIK if you upgrade package manager it should not affect petalinux tools unless you are using Ubuntu16.04 LTS.

 

You can try these below. 

 

$ sudo apt-get update
$ sudo apt-get install -y python tofrodos iproute2 gawk xvfb gcc git make net-tools libncurses5-dev tftpd zlib1g-dev libssl-dev flex bison libselinux1 gnupg wget diffstat chrpath socat xterm autoconf libtool tar unzip texinfo zlib1g-dev gcc-multilib build-essential libsdl1.2-dev libglib2.0-dev zlib1g:i386 screen pax

A2: Yes sudo is mandatory to install the packages.

 

Note: If you see anything broken please report to us we will help you.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------

View solution in original post

6 Replies
Moderator
Moderator
4,791 Views
Registered: ‎04-24-2017

Re: Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution

Hi @ronnywebers,

 

A1: 

On Ubuntu-16.04 LTS you no need to worry about upgrading the packagelist from apt pacakage manager. PetaLinux 2016.4 onwards is backend Yocto. AFAIK if you upgrade package manager it should not affect petalinux tools unless you are using Ubuntu16.04 LTS.

 

You can try these below. 

 

$ sudo apt-get update
$ sudo apt-get install -y python tofrodos iproute2 gawk xvfb gcc git make net-tools libncurses5-dev tftpd zlib1g-dev libssl-dev flex bison libselinux1 gnupg wget diffstat chrpath socat xterm autoconf libtool tar unzip texinfo zlib1g-dev gcc-multilib build-essential libsdl1.2-dev libglib2.0-dev zlib1g:i386 screen pax

A2: Yes sudo is mandatory to install the packages.

 

Note: If you see anything broken please report to us we will help you.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------

View solution in original post

Advisor ronnywebers
Advisor
3,080 Views
Registered: ‎10-10-2014

Re: Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution

Thanks @sandeepg, with my 2nd question I was maybe not really clear :

 

if I'm correct : by running 'aptitude upgrade' (with 'sudo' before it indeed, otherwise it won't run), all installed packages will be upgraded, I mean not only the packages that were installed for petalinux (as you show in your example command), but any installed package. I was wondering if upgrading all the packages could cause any incompatibility?

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
Moderator
Moderator
3,068 Views
Registered: ‎04-24-2017

Re: Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution

Hi @ronnywebers,

 

It should not be any problem when you upgrade the packages(xenial-updates). Also in your Ubuntu 16.04.01 LTS -> Software & Updates -> Updates -> Unsupported updates(xenial-backport) uncheck this option.

 

Also don't use any apt mirror sites which is not officially supported by Ubuntu-16.04.01 LTS.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
Advisor ronnywebers
Advisor
3,054 Views
Registered: ‎10-10-2014

Re: Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution

thanks @sandeepg, that clears up a lot!

 

last question before I close the topic - it's probably my misunderstanding : you wrote :

 

"AFAIK if you upgrade package manager it should not affect petalinux tools unless you are using Ubuntu16.04 LTS."

 

that phrase is confusing to me : you write 'unless', but indeed I am using Ubuntu 16.04.1 LTS . Should this phrase have been 'unless you're not using Ubuntu 16.04 LTS"?

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
Moderator
Moderator
3,041 Views
Registered: ‎04-24-2017

Re: Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution

Hi @ronnywebers,

 

Yes you are right my phrase was not clear.

 

In Ubuntu-16.04.1 LTS you can pull unsupported version of kernel and filesystem using apt source list mirror sites and you can override GRUB bootloader to use the unsupported kernel. This sometime affects update rc sysvinit resulting in broken apt package manager when you run sudo apt-get update/upgrade.

 

This affects petalinux installer tools.

Thanks,
Sandeep
PetaLinux Yocto | Embedded SW Support

---------------------------------------------------------------------------
Don’t forget to Reply, Kudo, and Accept as Solution.
---------------------------------------------------------------------------
0 Kudos
Visitor dhmcintire
Visitor
1,263 Views
Registered: ‎09-12-2018

Re: Installing Vivado 2017.2 on Ubuntu 16.04.1 LTS - additional libraries

Jump to solution
I just wanted to tack on a note for ubuntu that you also need the lsb-release package installed or you get a bunch of unary operator errors during the environment check. Normally this would be already installed, but if you run in a docker container its not necessarily present.
0 Kudos