UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant dtubbs
Participant
941 Views
Registered: ‎07-01-2016

PetaLinux 2018.2 build fails on u-boot ... undefined references to find_mmc_device, mmc_get_blk_desc, mmc_init

Subject line describes the issue for Ubuntu 16.04 LTS, PetaLinux 2018.2, Zynq7000

 

Sequence:

 

- Fresh install of a new project

- petalinux-config --get-hw-description  (updated config options)

- petalinux-config -c rootfs   (updated rootfs options)

- petalinux-config -c kernel   (updated kernel options)

-petalinux-build

 

then:

 

ERROR: Task (/opt/xilinx/petalinux/components/yocto/source/arm/layers/meta-xilinx/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-xlnx_2018.2.bb:do_compile) failed with exit code '1'

 

log shows:

 

...../build/tmp/work/plnx_zynq7-xilinx-linux-gnueabi/u-boot/xlnx/v2018.01-xilinx-v2018.2+gitAUTOINC+21812b5fd3-r0/git/drivers/dfu/dfu_mmc.c:30: undefined reference to 'find_mmc_device'

 

plus, same path and error with these functions:  mmc_get_blk_desc, mmc_init

 

Thanks for your help!

 

-Dave

 

0 Kudos
1 Reply
Adventurer
Adventurer
914 Views
Registered: ‎05-26-2017

Re: PetaLinux 2018.2 build fails on u-boot ... undefined references to find_mmc_device, mmc_get_blk_desc, mmc_init

If you dont need SD card functionality I'd recommend turning that config option off. 

 

If you do need it - The needed drivers are not being compiled in. Check the u-boot source code where find_mmc_device is defined and then look at the Makefile which option is needed. 

 

petalinux -c u-boot  

 

Is a safer way to add config options rather than manually adding .cfg files 

 

Regards, 

 

Otto

0 Kudos