cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
alionmgriffin
Participant
Participant
467 Views
Registered: ‎09-06-2018

Petalinux 2018.3 failed to source bitbake zynq7

Petalinux 2018.3 can not source bitbake when using a zc706 HDF. The Vivado design contains a Zynq IP block with board default settings. The Petalinux project has not modifications from the default. The machine names of template and zcu706 have been tried.

OS: Ubuntu 16.04 and Ubuntu 18.04

I believe the issue on lines 224 and 225 are the culprit. The 'arm' directory does not exist on the system as the error states. Both systems and a fresh install are missing this directory.

[INFO] generating Kconfig for project
INFO: [Hsi 55-1698] elapsed time for repository loading 0 seconds
[INFO] menuconfig project
/home/mgriffin/Desktop/project/build/misc/config/Kconfig.syshw:29:warning: defaults for choice values not supported
/home/mgriffin/Desktop/project/build/misc/config/Kconfig:630:warning: config symbol defined without type
[INFO] sourcing bitbake
environment: line 224: /tools/Xilinx/PetaLinux/2018.3/components/yocto/source/arm/environment-setup-cortexa9hf-neon-xilinx-linux-gnueabi: No such file or directory
environment: line 225: /tools/Xilinx/PetaLinux/2018.3/components/yocto/source/arm/layers/core/oe-init-build-env: No such file or directory
ERROR: Failed to source bitbake
ERROR: Failed to config project.

Is this a know issue with the Zynq7 processors? Is there a work around?

0 Kudos
2 Replies
aravindb
Moderator
Moderator
432 Views
Registered: ‎02-07-2018

HI @alionmgriffin 

Does  petalinux installation successful in your Ubuntu machine & also can you please check all the packages listed in this ug1144 are installed or not.

:https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_3/ug1144-petalinux-tools-reference-guide.pdf

Also try to run this below command :

sudo apt-get install zlib1g-dev zlib1g:i386

 

Thanks & regards

Aravind

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
---------------------------------------------------------------------------------------------

 

 

 

0 Kudos
alionmgriffin
Participant
Participant
424 Views
Registered: ‎09-06-2018

I can confirm that all packages are installed. I have attached my install log file from a fresh install.

Tags (1)
0 Kudos